dev-ruby/rails-html-sanitizer: add ruby27
authorHans de Graaff <graaff@gentoo.org>
Thu, 12 Mar 2020 10:46:13 +0000 (11:46 +0100)
committerHans de Graaff <graaff@gentoo.org>
Thu, 12 Mar 2020 10:55:33 +0000 (11:55 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/rails-html-sanitizer/rails-html-sanitizer-1.3.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-ruby/rails-html-sanitizer/rails-html-sanitizer-1.3.0-r1.ebuild b/dev-ruby/rails-html-sanitizer/rails-html-sanitizer-1.3.0-r1.ebuild
new file mode 100644 (file)
index 0000000..ef458c5
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Sanitize HTML fragments in Rails applications"
+HOMEPAGE="https://github.com/rafaelfranca/rails-html-sanitizer"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86 ~amd64-linux"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/loofah-2.3:0"
+
+ruby_add_bdepend "test? ( dev-ruby/rails-dom-testing )"
+
+all_ruby_prepare() {
+       # Avoid tests that depend on nokogiri patches to libxml2.
+       sed -i -e '/\(name_action\|attr\)_in_a_tag_in_safe_list_sanitizer/askip "libxml2"' test/sanitizer_test.rb || die
+}
+
+each_ruby_test() {
+       ${RUBY} -Ilib:test:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
+}