dev-lisp/cl-ppcre-unicode: Bump version to 2.1.0
authorChema Alonso Josa <nimiux@gentoo.org>
Mon, 27 Aug 2018 14:17:37 +0000 (16:17 +0200)
committerChema Alonso Josa <nimiux@gentoo.org>
Mon, 27 Aug 2018 14:17:37 +0000 (16:17 +0200)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-lisp/cl-ppcre-unicode/Manifest
dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.1.0.ebuild [new file with mode: 0644]

index 25c6a670503ff17c83e5e4f7afba656bcfb2686c..2ace7fade36c0834dc1b585b3536b82bdbd2fd3f 100644 (file)
@@ -1 +1,2 @@
 DIST cl-ppcre-2.0.11.tar.gz 158418 BLAKE2B d65aa1a565dbe6c9d10e4dafe323ab1332929e46e00ea2e9775ad940ed5ac983520c0e423daa17bf0173420d2269b5af2fd9b52f8d3dbcb0c778e03e61ef052d SHA512 c693c568065c0571e5509599018e58951425a857cec3793312af0d22e248e32233f924eafc8ba67fbedad38cb3f4efa11343b785b073eaac53c31871422488b1
+DIST cl-ppcre-2.1.0.tar.gz 159051 BLAKE2B d1b9dd93c3f4c4c3a23a7c01f28cc4a8cc8543bfa3280f60b53d61dadb377f9e45c0f79592323bb7dcaf06721d899159f958f5b7d391370eeb5c6ede81a7a0cd SHA512 c9c95c58628fd5ecebf6e24e0c26913719360c325e90e78c256d1306eb8c2cbe85a2a5f617fdb6c2a7091bd80f4021ad0d294371b2696ad8e5873eca13aab866
diff --git a/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.1.0.ebuild b/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.1.0.ebuild
new file mode 100644 (file)
index 0000000..8203612
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3
+
+DESCRIPTION="CL-PPCRE is a portable regular expression library for Common Lisp."
+HOMEPAGE="http://weitz.de/cl-ppcre/
+                 http://www.cliki.net/cl-ppcre"
+SRC_URI="https://github.com/edicl/cl-ppcre/archive/v${PV}.tar.gz -> cl-ppcre-${PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="=dev-lisp/cl-ppcre-${PV}
+               dev-lisp/cl-unicode"
+
+S="${WORKDIR}/cl-ppcre-${PV}"
+
+src_install() {
+       common-lisp-install-sources ${PN}/ test/unicode*
+       common-lisp-install-asdf ${PN}
+}