app-forensics/sleuthkit: remove '-Werror' from Makefiles
authorGöktürk Yüksek <gokturk@gentoo.org>
Wed, 6 May 2020 00:51:09 +0000 (20:51 -0400)
committerGöktürk Yüksek <gokturk@gentoo.org>
Wed, 6 May 2020 00:51:09 +0000 (20:51 -0400)
Closes: https://bugs.gentoo.org/713666
Package-Manager: Portage-2.3.69, Repoman-2.3.14
Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
app-forensics/sleuthkit/sleuthkit-4.9.0.ebuild

index fcc3132067ef72060b2882979d1d1cfda778191c..d335814552035d440cf5c80696b8044bde44d41f 100644 (file)
@@ -123,6 +123,11 @@ tsk_prepare_libewf() {
 src_prepare() {
        use ewf && tsk_prepare_libewf
 
+       # Do not pass '-Werror'. This is overkill for user builds.
+       sed -e '/AM_CXXFLAGS/ s/-Werror//g' \
+               -i tsk/util/Makefile.am \
+               -i tsk/pool/Makefile.am || die
+
        if use java; then
                pushd "${S}"/bindings/java &>/dev/null || die