Add support for USE=zlib.
authorMike Frysinger <vapier@gentoo.org>
Wed, 14 Feb 2007 07:14:18 +0000 (07:14 +0000)
committerMike Frysinger <vapier@gentoo.org>
Wed, 14 Feb 2007 07:14:18 +0000 (07:14 +0000)
Package-Manager: portage-2.1.2-r9

sys-apps/pciutils/ChangeLog
sys-apps/pciutils/pciutils-2.2.4-r1.ebuild
sys-apps/pciutils/pciutils-2.2.4.ebuild

index a0520211693a3fff592e4bd090423b2371b4df86..2ef60381b48b61eadca621ade99241e753a27587 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for sys-apps/pciutils
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.93 2007/02/13 15:15:51 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.94 2007/02/14 07:14:18 vapier Exp $
+
+  14 Feb 2007; Mike Frysinger <vapier@gentoo.org> pciutils-2.2.4.ebuild,
+  pciutils-2.2.4-r1.ebuild:
+  Add support for USE=zlib.
 
   13 Feb 2007; Gustavo Zacarias <gustavoz@gentoo.org> pciutils-2.2.4.ebuild:
   Stable on sparc
index 1c73171d4aeed2d4b4a7895ad07e8fc4db7b7d85..34ce12110a4b60499abd3ed1bd42afad4d3b7406 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.4-r1.ebuild,v 1.1 2007/02/10 00:30:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.4-r1.ebuild,v 1.2 2007/02/14 07:14:18 vapier Exp $
 
 inherit eutils flag-o-matic toolchain-funcs
 
@@ -11,9 +11,9 @@ SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE=""
+IUSE="zlib"
 
-DEPEND=""
+DEPEND="zlib? ( sys-libs/zlib )"
 
 src_unpack() {
        unpack ${A}
@@ -25,6 +25,7 @@ src_unpack() {
 }
 
 src_compile() {
+       export ZLIB=$(use zlib && echo yes || echo no)
        tc-export AR CC RANLIB
        emake OPT="${CFLAGS}" || die "emake failed"
 }
index 20f65ce4bd0c9692ab69850185377e7df4bde4b6..15dfe718307aca910728e563a81b3b94b2fcaff3 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.4.ebuild,v 1.3 2007/02/13 15:15:51 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.4.ebuild,v 1.4 2007/02/14 07:14:18 vapier Exp $
 
 inherit eutils flag-o-matic toolchain-funcs
 
@@ -11,9 +11,9 @@ SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh sparc ~x86 ~x86-fbsd"
-IUSE=""
+IUSE="zlib"
 
-DEPEND=""
+DEPEND="zlib? ( sys-libs/zlib )"
 
 src_unpack() {
        unpack ${A}
@@ -24,6 +24,7 @@ src_unpack() {
 }
 
 src_compile() {
+       export ZLIB=$(use zlib && echo yes || echo no)
        tc-export AR CC RANLIB
        emake OPT="${CFLAGS}" || die "emake failed"
 }