net-wireless/dump1090: wip update to fa fork
authorRick Farina <zerochaos@gentoo.org>
Wed, 3 Jul 2019 05:21:47 +0000 (01:21 -0400)
committerRick Farina <zerochaos@gentoo.org>
Wed, 3 Jul 2019 05:22:02 +0000 (01:22 -0400)
Package-Manager: Portage-2.3.67, Repoman-2.3.16
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
net-wireless/dump1090/dump1090-9999.ebuild
net-wireless/dump1090/metadata.xml

index 556e4a14a6980331f15ee8584d12679416e4f747..e4ab4ba0cfe880f54b314f6ca9ba10ac8ee0deae 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -9,34 +9,42 @@ DESCRIPTION="simple Mode S decoder for RTLSDR devices"
 #Original repo
 #HOMEPAGE="https://github.com/antirez/dump1090"
 #Repo that has actually been touched recenly
-HOMEPAGE="https://github.com/mutability/dump1090"
+#HOMEPAGE="https://github.com/mutability/dump1090"
+#And now we move to the next one in line
+HOMEPAGE="https://github.com/flightaware/dump1090"
 
 if [[ ${PV} == "9999" ]] ; then
        inherit git-r3
-       EGIT_REPO_URI="https://github.com/mutability/${PN}.git"
+       EGIT_REPO_URI="https://github.com/flightaware/${PN}.git"
        KEYWORDS=""
 else
        KEYWORDS="~amd64 ~x86"
-       COMMIT="fb5942dba6505a21cbafc7905a5a7c513b214dc9"
-       SRC_URI="https://github.com/mutability/dump1090/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-       S="${WORKDIR}/${PN}-${COMMIT}"
+       #COMMIT="fb5942dba6505a21cbafc7905a5a7c513b214dc9"
+       #SRC_URI="https://github.com/flightaware/dump1090/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+       #S="${WORKDIR}/${PN}-${COMMIT}"
+       SRC_URI="https://github.com/flightaware/dump1090/archive/v${PV}.tar.gz -> ${P}.tar.gz"
 fi
 
 LICENSE="BSD"
 SLOT="0"
-IUSE=""
+IUSE="bladerf +rtlsdr"
 
-RDEPEND="net-wireless/rtl-sdr
+RDEPEND="bladerf? ( net-wireless/bladerf:= )
+               rtlsdr? ( net-wireless/rtl-sdr:= )
+               sys-libs/ncurses:=
                virtual/libusb:1"
 DEPEND="${RDEPEND}"
 
+src_prepare() {
+       default
+       sed -i 's#-O2 -g -Wall -Werror -W##' Makefile
+       sed -i "s#-lncurses#$($(tc-getPKG_CONFIG) --libs ncurses)#" Makefile
+}
+
 src_compile() {
        emake CC="$(tc-getCC)" \
-               UNAME="Linux" \
-               DUMP1090_VERSION=${PV} \
-               CFLAGS="$($(tc-getPKG_CONFIG) --cflags librtlsdr) ${CFLAGS}" \
-               EXTRACFLAGS="-DHTMLPATH=\\\"/usr/share/dump1090/html\\\"" \
-               LIBS="${LDFLAGS} $($(tc-getPKG_CONFIG) --libs librtlsdr) -lm -lpthread"
+               BLADERF=$(usex bladerf) \
+               RTLSDR=$(usex rtlsdr)
 }
 
 src_install() {
@@ -50,6 +58,5 @@ src_install() {
        insinto /usr/share/${PN}/tools
        doins -r tools/*
 
-       newdoc debian/lighttpd/89-dump1090.conf lighttpd.conf
-       newdoc debian/nginx/dump1090-mutability nginx.conf
+       newdoc debian/lighttpd/89-dump1090-fa.conf lighttpd.conf
 }
index 88faf189fed3fd68aee294daa0cd3616ee6e40ff..da238ebeece0836dc3b95faf4231befe87193799 100644 (file)
@@ -5,7 +5,11 @@
                <email>radio@gentoo.org</email>
                <name>Radio</name>
        </maintainer>
+       <use>
+               <flag name="bladerf">Build with Nuand BladeRF support</flag>
+               <flag name="rtlsdr">Build with Realtek RTL2832U (rtlsdr) support</flag>
+       </use>
        <upstream>
-               <remote-id type="github">antirez/dump1090</remote-id>
+               <remote-id type="github">flightaware/dump1090</remote-id>
        </upstream>
 </pkgmetadata>