dev-python/pytest-mock: exclude two additional introspection tests
authorAaron Bauman <bman@gentoo.org>
Mon, 2 Dec 2019 19:26:58 +0000 (14:26 -0500)
committerAaron Bauman <bman@gentoo.org>
Mon, 2 Dec 2019 19:27:23 +0000 (14:27 -0500)
Signed-off-by: Aaron Bauman <bman@gentoo.org>
dev-python/pytest-mock/pytest-mock-1.11.2.ebuild

index 9abdcee85b10b4e88b5054717d7e52d580ebaee3..93d187c92726973892d6dd9d9eef0c4080f9d6b4 100644 (file)
@@ -2,6 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
+
 PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
 
 inherit distutils-r1
@@ -29,6 +30,8 @@ src_prepare() {
        sed -e 's|^\(    def \)\(test_failure_message_with_no_name(\)|\1_\2|' \
                -e 's|^\(    def \)\(test_failure_message_with_name(\)|\1_\2|' \
                -e 's|^\(def \)\(test_detailed_introspection(\)|\1_\2|' \
+               -e 's|^\(def \)\(test_assert_called_args_with_introspection(\)|\1_\2|' \
+               -e 's|^\(def \)\(test_assert_called_kwargs_with_introspection(\)|\1_\2|' \
                -i tests/test_pytest_mock.py || die
        distutils-r1_src_prepare
 }