net-im/toxic: version bump
authorDaniel Campbell <zlg@gentoo.org>
Wed, 22 Feb 2017 09:18:41 +0000 (01:18 -0800)
committerDaniel Campbell <zlg@gentoo.org>
Wed, 22 Feb 2017 09:18:41 +0000 (01:18 -0800)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

net-im/toxic/Manifest
net-im/toxic/toxic-0.7.2.ebuild [new file with mode: 0644]

index ecea0ac23e5088a59b1f9f855a68e74ae10d5e2f..68d914717052647010ed2a6cb80b61d69fb45a9e 100644 (file)
@@ -1 +1,2 @@
 DIST toxic-0.7.1.tar.gz 1137112 SHA256 414ca2cd369e277872c7248c43f82afa0ac2f6c8fa5fc8e93f7c3e8ab6d11b9c SHA512 c304b07a67ed27a25394590eb8759b5dd957605be4eb9e64590d4580da0977e1cd201e8b95ae1b31e995772560510ceb0643028696e2df69e1f5d0dff575b553 WHIRLPOOL 228193bb78bf38bd5f5f5ff371a87f12561edcb5729337b58198df36e5ec55b99f2c2ca84f5b471846e7f84445f1c5181c5fa71ff287f62d5e34f833a45747d6
+DIST toxic-0.7.2.tar.gz 1136947 SHA256 a2962aca766caf84b52a52e9a5ce2276a9d3906685f565d2a00551e7c2916c59 SHA512 cf3fd0afdc63aa4d2039e08a8f9f32a042a6412f0a242823205fcf058f56e732468389d4bdf614ded8b0d9704b05a315044ee216edd51546501a24be0b6d5b26 WHIRLPOOL 47b5ee57a38084ea7dcff12cac77b05a2d8d486f0ecaffe5e5db11825338a785a96563e10abcb788accea527d2da6f690b326628dd09601d2bf002f69cc60de3
diff --git a/net-im/toxic/toxic-0.7.2.ebuild b/net-im/toxic/toxic-0.7.2.ebuild
new file mode 100644 (file)
index 0000000..3f2723f
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A curses-based client for Tox."
+HOMEPAGE="https://github.com/JFreegman/toxic"
+SRC_URI="https://github.com/JFreegman/toxic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+X +av notifications"
+
+RDEPEND="
+       net-libs/tox:0/0.0[av?]
+       dev-libs/libconfig
+       media-gfx/qrencode
+       net-misc/curl
+       sys-libs/ncurses:0=
+       av? ( media-libs/openal media-libs/freealut )
+       notifications? ( x11-libs/libnotify )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+       if ! use av; then
+               export DISABLE_AV=1
+               export DISABLE_SOUND_NOTIFY=1
+       fi
+       if ! use X; then
+               export DISABLE_X11=1
+       fi
+       if ! use notifications; then
+               export DISABLE_DESKTOP_NOTIFY=1
+       fi
+       sed -i \
+               -e "s,/usr/local,${EPREFIX}/usr,g" \
+               cfg/global_vars.mk || die "PREFIX sed failed"
+}
+
+src_install() {
+       default
+       if ! use av; then
+               rm -r "${ED%/}"/usr/share/${PN}/sounds || die "Could not remove sound dir"
+       fi
+}