net-analyzer/tcpreplay: drop vulnerable wrt bug #678266
authorAaron Bauman <bman@gentoo.org>
Sat, 20 Apr 2019 02:26:56 +0000 (22:26 -0400)
committerAaron Bauman <bman@gentoo.org>
Sat, 20 Apr 2019 02:26:56 +0000 (22:26 -0400)
Signed-off-by: Aaron Bauman <bman@gentoo.org>
net-analyzer/tcpreplay/Manifest
net-analyzer/tcpreplay/tcpreplay-4.3.1.ebuild [deleted file]

index 2c486a839804cdac821e54eb15de974c469fd9dc..6dd98931a73cf56f96e6a394e9fcca5b0c2c321d 100644 (file)
@@ -1,2 +1 @@
-DIST tcpreplay-4.3.1.tar.xz 746804 BLAKE2B c1feb541b8243b00b2fa6ee9742ced4ef47c58a58d3a95be88faa0fa4301da0cb962a620df724cd4526ea31e74a0e7d7161eb44afea37467a19976a20855e0e0 SHA512 2dbad1a88ed19db897cc1222883c02eb7f0808f64cafb3c3ef8f21c0cfcb14d3ebb92a8a01ea203ca128ed675d2e7dcdb30d0bce30eb79e729d9d45d309f9220
 DIST tcpreplay-4.3.2.tar.xz 747268 BLAKE2B 27cad902785975f9c7fbfb8abef24ae95fbc8812e0a4fabd3b1ecf74bb9f0a99cdb0c37db72c433296d3cebba89d0bbc90e944195e585bf2d1c2d93ef234c4f6 SHA512 641dd636d9c5c30637d0103f8b21da3ce234f9e3ed7ab4d2b20d004fc4a14301672dcd678b2d5e0eb90d55a97bcb0c4c67f31c790a5aa3c509a92d1142c5b7b9
diff --git a/net-analyzer/tcpreplay/tcpreplay-4.3.1.ebuild b/net-analyzer/tcpreplay/tcpreplay-4.3.1.ebuild
deleted file mode 100644 (file)
index 3d0c5b4..0000000
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit autotools flag-o-matic
-
-DESCRIPTION="utilities for editing and replaying previously captured network traffic"
-HOMEPAGE="http://tcpreplay.appneta.com/ https://github.com/appneta/tcpreplay"
-LICENSE="BSD GPL-3"
-SRC_URI="https://github.com/appneta/${PN}/releases/download/v${PV/_/-}/${P/_/-}.tar.xz -> ${P}.tar.xz"
-
-SLOT="0"
-KEYWORDS="amd64 ~arm ~sparc x86"
-IUSE="debug pcapnav +tcpdump"
-
-DEPEND="
-       >=sys-devel/autogen-5.18.4[libopts]
-       dev-libs/libdnet
-       >=net-libs/libpcap-0.9
-       tcpdump? ( net-analyzer/tcpdump )
-       pcapnav? ( net-libs/libpcapnav )
-"
-RDEPEND="${DEPEND}"
-
-DOCS=(
-       docs/{CHANGELOG,CREDIT,HACKING,TODO}
-)
-PATCHES=(
-       "${FILESDIR}"/${PN}-4.3.0-enable-pcap_findalldevs.patch
-)
-
-S=${WORKDIR}/${P/_/-}
-
-src_prepare() {
-       default
-
-       sed -i \
-               -e 's|#include <dnet.h>|#include <dnet/eth.h>|g' \
-               src/common/sendpacket.c || die
-       sed -i \
-               -e 's|@\([A-Z_]*\)@|$(\1)|g' \
-               -e '/tcpliveplay_CFLAGS/s|$| $(LDNETINC)|g' \
-               -e '/tcpliveplay_LDADD/s|$| $(LDNETLIB)|g' \
-               src/Makefile.am || die
-
-       eautoreconf
-}
-
-src_configure() {
-       # By default it uses static linking. Avoid that, bug 252940
-       econf \
-               $(use_enable debug) \
-               $(use_with pcapnav pcapnav-config /usr/bin/pcapnav-config) \
-               $(use_with tcpdump tcpdump /usr/sbin/tcpdump) \
-               --enable-dynamic-link \
-               --enable-local-libopts \
-               --enable-shared \
-               --with-libdnet \
-               --with-testnic2=lo \
-               --with-testnic=lo
-}
-
-src_test() {
-       if [[ ! ${EUID} -eq 0 ]]; then
-               ewarn "Some tests were disabled due to FEATURES=userpriv"
-               ewarn "To run all tests issue the following command as root:"
-               ewarn " # make -C ${S}/test"
-               emake -j1 -C test tcpprep || die "self test failed - see ${S}/test/test.log"
-       else
-               emake -j1 test || {
-                       ewarn "Note that some tests require eth0 iface to be up." ;
-                       die "self test failed - see ${S}/test/test.log" ; }
-       fi
-}