sys-kernel/git-sources: Linux patch 5.2-rc4
authorMike Pagano <mpagano@gentoo.org>
Sun, 9 Jun 2019 16:14:44 +0000 (12:14 -0400)
committerMike Pagano <mpagano@gentoo.org>
Sun, 9 Jun 2019 16:14:54 +0000 (12:14 -0400)
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

sys-kernel/git-sources/Manifest
sys-kernel/git-sources/git-sources-5.2_rc4.ebuild [new file with mode: 0644]

index 8558ec0d9f21b217c0c4824fe3831d11583c573c..a302f35f4cd59beccd11cedfcd7947eabd3cd4c5 100644 (file)
@@ -2,3 +2,4 @@ DIST linux-5.1.tar.xz 106244476 BLAKE2B ae3c63ced819737e34f8ec3a78138f87704a2f29
 DIST patch-5.2-rc1.patch 46729627 BLAKE2B e6096414073f46d0bd9ec3a8f0f2594344ebea66d0f803902175bf37c82cdc68c32b9c4bb45515be8bbed4ae82fad90319b304cbf849c9ca75f9aa6c390c7d87 SHA512 12cb66e4680b0fc74fb22c9f4a02905b8feae724be7c51dc69725aeb839c817d964537193b5738d85fd4ee4d8544be2864a33814f4b64d1468dc0b17a05a40e9
 DIST patch-5.2-rc2.patch 49912438 BLAKE2B 38140ffd6b0d62b43fc0d657e28a384d2887cc1f961c10d631dc4b2826c8ec82e6db947ff0d0e5f3586e115eb4f976231aa51bc005786f129ce59dd5c053f8be SHA512 4df97c0911b3fc0c186ef81a204c0633660f9484583fbf76e2c15ed3a60bf31c9caf9cda46232034fcae87ad6ab53bedd52f420b4db446c6c888cd63942fd615
 DIST patch-5.2-rc3.patch 56859377 BLAKE2B 15f2fab5ef83a06efbe1a40fc1423d7c4fbd725b0869dc9d9d00d920a17aad9e3aa2f7a68200e38bd14971a90e692b7b55d45bde4ae8d2027fa4c3d2e1c5462f SHA512 07a97b869f751d9cbf4a4bd8df79a496c63320a24a4b165f684263fe679f3c3df58f3aafa560b9d94b05c6ea302146eadb9c4c5d83bc9e0d0cddba9c5d0bcac5
+DIST patch-5.2-rc4.patch 60202893 BLAKE2B 0b87ff128da720388b11243143bb15daaa27db66f363a5c89034b92b0cf5eb9dcdc7f4a6fa78bde409e389600f0361ab6574e2d3eb5318dd91cec6271ff507da SHA512 ae5d8cf7ae969dc5fa30faa0b0f29c783071b45f07fa9e73768095da896a5cea7d91f5545986ea7ce659a5cd09ce861f68df75264565a10f87abde6490fc4a46
diff --git a/sys-kernel/git-sources/git-sources-5.2_rc4.ebuild b/sys-kernel/git-sources/git-sources-5.2_rc4.ebuild
new file mode 100644 (file)
index 0000000..8509b23
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.1"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+       postinst_sources
+}