dev-python/rope: Version bump 0.16.0 and add py3_7
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>
Sun, 26 Jan 2020 18:56:04 +0000 (19:56 +0100)
committerMatt Turner <mattst88@gentoo.org>
Sat, 15 Feb 2020 20:37:59 +0000 (12:37 -0800)
Package-Manager: Portage-2.3.85, Repoman-2.3.20
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-python/rope/Manifest
dev-python/rope/rope-0.16.0.ebuild [new file with mode: 0644]

index 42042b0e90ba0340eb77950cac14cac5a3542abe..c210a442a215ce78f08583e4f1458f05cd28f264 100644 (file)
@@ -1 +1,2 @@
 DIST rope-0.10.7.tar.gz 244089 BLAKE2B aebc1eaa3715aa4f2423490790f53040ad256fca35b3ad7b516e6b1f0af051b79f812f7b701ff5ac2414dbf2d1cba319da0f4cf241041329c0c750ae63e0ec33 SHA512 80343b8b7af883afbd04734b0fe4dbdab114301234654cbd95b3ae8be8dff40878105b7647209f5e899b981ab6a7ecb987d9bdf942b32ed083c745128c22ef95
+DIST rope-0.16.0.tar.gz 243304 BLAKE2B 2c41572687ef245eb20abfccebcc9f12ecaa177be313cec59c85be5102b7358566570730a7140f952b0a1c515b479c3d21740d32d4678e65c4c572acf86f4e27 SHA512 33ba57b246337e413126309a521c54e861899b03fd250e148b97d9789cddf6eceab36609ea6e36e84ad1ac514bc3363f4937b01bcb96b6103c2a33bec1d4fb75
diff --git a/dev-python/rope/rope-0.16.0.ebuild b/dev-python/rope/rope-0.16.0.ebuild
new file mode 100644 (file)
index 0000000..a60999b
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="https://github.com/python-rope/rope"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc"
+
+# Dependency for docbuild documentation which is not noted in
+# setup.py, using standard docutils builds docs successfully.
+DEPEND="doc? ( dev-python/docutils[${PYTHON_USEDEP}] )"
+
+python_test() {
+       PYTHONPATH="${BUILD_DIR}/lib:." ${EPYTHON} ropetest/__init__.py
+}
+
+python_compile_all() {
+       if use doc; then
+               pushd docs > /dev/null || die
+               mkdir build || die
+               local i
+               for i in ./*.rst; do
+                       rst2html.py $i > ./build/${i/rst/html} || die
+               done
+               popd > /dev/null || die
+       fi
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/build/. )
+       distutils-r1_python_install_all
+}