net-im/skypeforlinux: version bump to 8.28.0.41
authorNikos Chantziaras <realnc@gmail.com>
Fri, 17 Aug 2018 13:00:10 +0000 (16:00 +0300)
committerAmy Liffey <amynka@gentoo.org>
Sat, 18 Aug 2018 06:17:58 +0000 (07:17 +0100)
Closes: https://bugs.gentoo.org/663874
Package-Manager: Portage-2.3.46, Repoman-2.3.10

net-im/skypeforlinux/Manifest
net-im/skypeforlinux/skypeforlinux-8.28.0.41.ebuild [new file with mode: 0644]

index 5c15c3d46f7c0104cd64d85e177a3a29042950ab..0940676a03290d6105e229e4093813e93729fcee 100644 (file)
@@ -1,3 +1,4 @@
 DIST skypeforlinux_8.22.0.2-1.x86_64.rpm 96073264 BLAKE2B d5d85ac5ba852ef50286894a4a3ff830e3763eb962f8e40cf4d2b9a9511394113991bd0de6cfe54fb8286c5bbe25ce516a640097f9240a947c7e70c97c7bcec9 SHA512 c628bcde1a467bf69e66bd8fc134bba18a2489d857659d386addb0659492bdc7884c29087411d5728074ae7f108f98be876b6330b1178e8ffe9792662bc9105f
 DIST skypeforlinux_8.25.0.5-1.x86_64.rpm 90947986 BLAKE2B af778f6bad5440a97186d4ca6ef61c8d22099dd9958aa6176b77cd5bfd8ebced8e914df0a4c71ec5c6a7374af5650fbb2fe86592c0b0512792910f02b4ddacbe SHA512 009a6403a4a3188c9054354629a993b3eff120d45af275b19ddfe4a28c9e9b3de2058913069bf6439e92bf9f087e0b795f35bff1c4e8e313730fa951735d981e
 DIST skypeforlinux_8.27.0.85-1.x86_64.rpm 94874950 BLAKE2B b96f79e66aa6b4e85abee2cbd7a94500f344c31ad3f0863a0bb5b360646b558823b6c289394f98cbc98da66bdbc7916e27aadbae15a0cb422cef10841cbf4679 SHA512 c30fd1d41c407719b480e2d04d18d192c585f33396f8923667d255309f9dcb7e258a4bc4383808872be728bada7f06d799be8c84930e8154c01771297f5d6fc2
+DIST skypeforlinux_8.28.0.41-1.x86_64.rpm 95603274 BLAKE2B 97698ab5dd7187471323e62ed43b6df8d1271eb4a7c2312bf4e271e31e193427888253610ca1132df61010e4260bafc73b8602945ba15fad1b89750aaab547e5 SHA512 11ebed4e273ab755da605be023642ed37eb6e66d48923fbfec2bf4fda40f64a0d89764016bfb4a3818bdcac9582d5510076ad83e1e50dfaeec35a2f9aa405eda
diff --git a/net-im/skypeforlinux/skypeforlinux-8.28.0.41.ebuild b/net-im/skypeforlinux/skypeforlinux-8.28.0.41.ebuild
new file mode 100644 (file)
index 0000000..fe78794
--- /dev/null
@@ -0,0 +1,116 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit desktop gnome2-utils pax-utils rpm multilib-build xdg-utils
+
+DESCRIPTION="Instant messaging client, with support for audio and video"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"
+
+LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="pax_kernel"
+
+S="${WORKDIR}"
+QA_PREBUILT="*"
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="
+       app-crypt/libsecret[${MULTILIB_USEDEP}]
+       dev-libs/atk[${MULTILIB_USEDEP}]
+       dev-libs/expat[${MULTILIB_USEDEP}]
+       dev-libs/glib:2[${MULTILIB_USEDEP}]
+       dev-libs/nspr[${MULTILIB_USEDEP}]
+       dev-libs/nss[${MULTILIB_USEDEP}]
+       gnome-base/gconf:2[${MULTILIB_USEDEP}]
+       media-libs/alsa-lib[${MULTILIB_USEDEP}]
+       media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+       media-libs/freetype:2[${MULTILIB_USEDEP}]
+       media-libs/libv4l[${MULTILIB_USEDEP}]
+       net-print/cups[${MULTILIB_USEDEP}]
+       sys-apps/dbus[${MULTILIB_USEDEP}]
+       sys-devel/gcc[cxx]
+       virtual/ttf-fonts
+       x11-libs/cairo[${MULTILIB_USEDEP}]
+       x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+       x11-libs/gtk+:2[${MULTILIB_USEDEP}]
+       x11-libs/libX11[${MULTILIB_USEDEP}]
+       x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
+       x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+       x11-libs/libXcursor[${MULTILIB_USEDEP}]
+       x11-libs/libXdamage[${MULTILIB_USEDEP}]
+       x11-libs/libXext[${MULTILIB_USEDEP}]
+       x11-libs/libXfixes[${MULTILIB_USEDEP}]
+       x11-libs/libXi[${MULTILIB_USEDEP}]
+       x11-libs/libXrandr[${MULTILIB_USEDEP}]
+       x11-libs/libXrender[${MULTILIB_USEDEP}]
+       x11-libs/libXtst[${MULTILIB_USEDEP}]
+       x11-libs/libxcb[${MULTILIB_USEDEP}]
+       x11-libs/libxkbfile[${MULTILIB_USEDEP}]
+       x11-libs/pango[${MULTILIB_USEDEP}]"
+
+src_unpack() {
+       rpm_src_unpack ${A}
+}
+
+src_prepare() {
+       default
+       sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+               -i usr/bin/skypeforlinux || die
+       sed -e "s!^Exec=/usr/!Exec=${EPREFIX}/opt/!" \
+               -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+               -e "/^OnlyShowIn=/d" \
+               -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+       dodir /opt
+       cp -a usr/share/skypeforlinux "${D}"/opt || die
+
+       into /opt
+       dobin usr/bin/skypeforlinux
+
+       dodoc usr/share/skypeforlinux/*.html
+       dodoc -r usr/share/doc/skypeforlinux/.
+       # symlink required for the "Help->3rd Party Notes" menu entry  (otherwise frozen skype -> xdg-open)
+       dosym ${P} usr/share/doc/skypeforlinux
+
+       doicon usr/share/pixmaps/skypeforlinux.png
+
+       # compat symlink for the autostart desktop file
+       dosym ../../opt/bin/skypeforlinux usr/bin/skypeforlinux
+
+       local res
+       for res in 16 32 256 512; do
+               newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+       done
+
+       domenu usr/share/applications/skypeforlinux.desktop
+
+       if use pax_kernel; then
+               pax-mark -m "${ED%/}"/opt/skypeforlinux/skypeforlinux
+               pax-mark -m "${ED%/}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+               ewarn "You have set USE=pax_kernel meaning that you intend to run"
+               ewarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+               ewarn "the ${PN} binary itself and this *may* lead to breakage! If"
+               ewarn "you suspect that ${PN} is being broken by this modification,"
+               ewarn "please open a bug."
+       fi
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
+       gnome2_icon_cache_update
+}