dev-php/PEAR-OLE: new EAPI=6 revision sans the php-pear-r1 eclass.
authorMichael Orlitzky <mjo@gentoo.org>
Sun, 8 Jan 2017 21:34:25 +0000 (16:34 -0500)
committerMichael Orlitzky <mjo@gentoo.org>
Sun, 8 Jan 2017 21:34:42 +0000 (16:34 -0500)
Package-Manager: portage-2.3.0

dev-php/PEAR-OLE/PEAR-OLE-1.0.0_rc2-r1.ebuild [new file with mode: 0644]
dev-php/PEAR-OLE/PEAR-OLE-1.0.0_rc2.ebuild [deleted file]
dev-php/PEAR-OLE/metadata.xml

diff --git a/dev-php/PEAR-OLE/PEAR-OLE-1.0.0_rc2-r1.ebuild b/dev-php/PEAR-OLE/PEAR-OLE-1.0.0_rc2-r1.ebuild
new file mode 100644 (file)
index 0000000..417452c
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV^^}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Package for reading and writing OLE containers"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/php:*
+       dev-php/PEAR-PEAR"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+       insinto /usr/share/php
+       doins "${MY_PN}.php"
+       doins -r "${MY_PN}"
+}
diff --git a/dev-php/PEAR-OLE/PEAR-OLE-1.0.0_rc2.ebuild b/dev-php/PEAR-OLE/PEAR-OLE-1.0.0_rc2.ebuild
deleted file mode 100644 (file)
index 602a4f9..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit php-pear-r1
-
-DESCRIPTION="Package for reading and writing OLE containers"
-LICENSE="PHP-2.02 PHP-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE=""
index aca42932b83363b2b3b1f1ff5c7ce1ccccf24838..8ccf2b59195bfc274b63503e932f2694e5e2e802 100644 (file)
@@ -1,8 +1,11 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<maintainer type="project">
-       <email>php-bugs@gentoo.org</email>
-       <name>PHP</name>
-</maintainer>
+  <maintainer type="project">
+    <email>php-bugs@gentoo.org</email>
+    <name>PHP</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="github">pear/OLE</remote-id>
+  </upstream>
 </pkgmetadata>