games-arcade/openmortal: Stop using games.eclass
authorPacho Ramos <pacho@gentoo.org>
Sun, 22 Apr 2018 19:47:56 +0000 (21:47 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sun, 22 Apr 2018 19:48:39 +0000 (21:48 +0200)
Package-Manager: Portage-2.3.31, Repoman-2.3.9

games-arcade/openmortal/files/openmortal-0.7-gcc41.patch
games-arcade/openmortal/openmortal-0.7-r2.ebuild [new file with mode: 0644]

index 1c10ce2ba3d4051191fcec3a470631cef52e626c..2620c153e837f214432daae54bcf232a23174217 100644 (file)
@@ -1,5 +1,5 @@
---- src/OnlineChat.cpp.old
-+++ src/OnlineChat.cpp
+--- a/src/OnlineChat.cpp.old
++++ b/src/OnlineChat.cpp
 @@ -56,7 +56,7 @@
  class CChallengeMenu: public Menu
  {
diff --git a/games-arcade/openmortal/openmortal-0.7-r2.ebuild b/games-arcade/openmortal/openmortal-0.7-r2.ebuild
new file mode 100644 (file)
index 0000000..025e21b
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools desktop
+
+DESCRIPTION="A spoof of the famous Mortal Kombat game"
+HOMEPAGE="http://openmortal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[video]
+       media-libs/sdl-image
+       media-libs/sdl-mixer
+       media-libs/sdl-ttf
+       media-libs/sdl-net
+       >=media-libs/freetype-2.4.0:2
+       dev-lang/perl
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       default
+       eapply \
+               "${FILESDIR}/${P}"-gcc41.patch \
+               "${FILESDIR}/${P}"-freetype.patch
+       mv configure.{in,ac} || die
+       eautoreconf
+}
+
+src_install() {
+       default
+       newicon data/gfx/icon.png ${PN}.png
+       make_desktop_entry ${PN} OpenMortal
+}