dev-python/libasyncns-python: fix build with glibc-2.25.
authorAlexander Tsoy <alexander@tsoy.me>
Wed, 20 Sep 2017 15:10:44 +0000 (18:10 +0300)
committerPatrice Clement <monsieurp@gentoo.org>
Sat, 23 Sep 2017 19:40:13 +0000 (21:40 +0200)
Gentoo-Bug: https://bugs.gentoo.org/609388
Closes: https://github.com/gentoo/gentoo/pull/5739

dev-python/libasyncns-python/files/libasyncns-python-0.7.1-glibc-2.25.patch [new file with mode: 0644]
dev-python/libasyncns-python/libasyncns-python-0.7.1-r1.ebuild

diff --git a/dev-python/libasyncns-python/files/libasyncns-python-0.7.1-glibc-2.25.patch b/dev-python/libasyncns-python/files/libasyncns-python-0.7.1-glibc-2.25.patch
new file mode 100644 (file)
index 0000000..6ec84aa
--- /dev/null
@@ -0,0 +1,14 @@
+https://sourceware.org/git/?p=glibc.git;a=patch;h=4f157746e0c713965d9143b52fef606312087c48
+
+diff --git a/libasyncns-python-0.7.1/libasyncns.c b/libasyncns-python-0.7.1/libasyncns.c
+index 99a73de..5e3da0b 100644
+--- a/libasyncns-python-0.7.1/libasyncns.c
++++ b/libasyncns-python-0.7.1/libasyncns.c
+@@ -134,7 +134,6 @@ PyMODINIT_FUNC initlibasyncns(void)
+       ADDNSCONST(ns_t_mailb);
+       ADDNSCONST(ns_t_maila);
+       ADDNSCONST(ns_t_any);
+-      ADDNSCONST(ns_t_zxfr);
+       ADDNSCONST(ns_t_max);
+       
+       ADDNSCONST(ns_c_invalid);
index 1b8e56d00254af9a1565c602ebe10e2866e96b87..2c5ab37721e6c122f7956bfc45a43692462451aa 100644 (file)
@@ -18,6 +18,8 @@ IUSE=""
 DEPEND=">=net-libs/libasyncns-0.4"
 RDEPEND="${DEPEND}"
 
+PATCHES=( "${FILESDIR}/${PN}-0.7.1-glibc-2.25.patch" )
+
 python_compile() {
        if [[ ${EPYTHON} != python3* ]]; then
                local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"