dev-libs/libmateweather: Fix dependency versions
authorNP-Hardass <NP-Hardass@gentoo.org>
Sun, 12 May 2019 20:20:07 +0000 (16:20 -0400)
committerGöktürk Yüksek <gokturk@gentoo.org>
Sun, 12 May 2019 21:01:14 +0000 (17:01 -0400)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
dev-libs/libmateweather/libmateweather-1.22.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-libs/libmateweather/libmateweather-1.22.0-r1.ebuild b/dev-libs/libmateweather/libmateweather-1.22.0-r1.ebuild
new file mode 100644 (file)
index 0000000..2fef435
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+       KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="MATE library to access weather information from online services"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="debug"
+
+COMMON_DEPEND=">=dev-libs/glib-2.50:2
+       >=dev-libs/libxml2-2.6:2
+       >=net-libs/libsoup-2.34:2.4
+       >=sys-libs/timezone-data-2010k:0
+       x11-libs/gdk-pixbuf:2
+       virtual/libintl:0
+       >=x11-libs/gtk+-3.22:3"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+       dev-util/gtk-doc
+       dev-util/gtk-doc-am
+       >=dev-util/intltool-0.50.1:*
+       sys-devel/gettext:*
+       >=sys-devel/libtool-2.2.6:2
+       virtual/pkgconfig:*"
+
+src_configure() {
+       mate_src_configure \
+               --enable-locations-compression \
+               --disable-all-translations-in-one-xml \
+               --disable-icon-update
+}