dev-libs/jsoncpp: Bump to 1.9.3_pre20200412 snapshot
authorMichał Górny <mgorny@gentoo.org>
Mon, 13 Apr 2020 11:38:06 +0000 (13:38 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 13 Apr 2020 12:07:29 +0000 (14:07 +0200)
Closes: https://bugs.gentoo.org/716254
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-libs/jsoncpp/Manifest
dev-libs/jsoncpp/jsoncpp-1.9.3_pre20200412.ebuild [new file with mode: 0644]

index 1727cd762c7556c0f7f21b0aa5cb2cf2ee5912b5..f4b895433b53b46b78011b01e0e0f9a2d928512d 100644 (file)
@@ -1,2 +1,3 @@
 DIST jsoncpp-1.9.1.tar.gz 203067 BLAKE2B 654f39b1265b344bb24d3fefb34d4d8b44f69ec819f333f00033ef90acfd5b926fdcc743badf403af797a6f58fe58d195ec0cdf4a1514629f8a1e75c20a6e2f6 SHA512 4a8352e1d32c0ba8a0aea4df1663279cb2256b334643c5b62be37dfb5951e06900ba38c010d1201511fcf7de09137d6a4b886edbb2b99160d2f62b5f4679f766
 DIST jsoncpp-1.9.2.tar.gz 211341 BLAKE2B 9081bf2b2599194c1c77476287e34aaeacc3c331147db79e3343eae28321e55dbfc8d74faf899912c257194030d39eac4fdb016a68290755badd1b68b0a69dd4 SHA512 7c7188199d62ae040d458d507ba62f0370c53f39c580760ee5485cae5c08e5ced0c9aea7c14f54dfd041999a7291e4d0f67f8ccd8b1030622c85590774688640
+DIST jsoncpp-1.9.3_pre20200412.tar.gz 212522 BLAKE2B 17b0cc2ef40ae932c6ff26c0fa77e8326099a1b6f088e53697c2a3c286d23ef63dd372f2ba721025b84670957689251c2d15083bdd24565715a78beac556ead2 SHA512 6e58870c5c478fe2bba125c50c4f77654f304051f4091cc5a98f9a3c9aefbb94d1156eb07ce004a7683675fd971ec825a0828803042d9b03783b1debf3a39e2b
diff --git a/dev-libs/jsoncpp/jsoncpp-1.9.3_pre20200412.ebuild b/dev-libs/jsoncpp/jsoncpp-1.9.3_pre20200412.ebuild
new file mode 100644 (file)
index 0000000..7011d73
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit meson python-any-r1
+
+EGIT_COMMIT="90ca694e4697497a8c2bc8c60a9c9f89e7290a10"
+DESCRIPTION="C++ JSON reader and writer"
+HOMEPAGE="https://github.com/open-source-parsers/jsoncpp"
+SRC_URI="
+       https://github.com/open-source-parsers/${PN}/archive/${EGIT_COMMIT}.tar.gz
+               -> ${P}.tar.gz"
+S=${WORKDIR}/${PN}-${EGIT_COMMIT}
+
+LICENSE="|| ( public-domain MIT )"
+SLOT="0/23"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+       ${PYTHON_DEPS}
+       doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_configure() {
+       local emesonargs=(
+               # Follow Debian, Ubuntu, Arch convention for headers location
+               # bug #452234
+               --includedir include/jsoncpp
+               -Dtests=$(usex test true false)
+       )
+       meson_src_configure
+}
+
+src_compile() {
+       meson_src_compile
+
+       if use doc; then
+               echo "${PV}" > version || die
+               "${EPYTHON}" doxybuild.py --doxygen="${EPREFIX}"/usr/bin/doxygen || die
+               HTML_DOCS=( dist/doxygen/jsoncpp*/. )
+       fi
+}