net-misc/dhcpcd: Removed broken version
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 13 Nov 2019 11:09:06 +0000 (12:09 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 13 Nov 2019 11:12:47 +0000 (12:12 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-misc/dhcpcd/Manifest
net-misc/dhcpcd/dhcpcd-8.1.1.ebuild [deleted file]

index 8177c14864b4e7495a2118b5dc5ce38c11e58f12..141f812738724ca0aa921a423f842dfcce85be2a 100644 (file)
@@ -1,4 +1,3 @@
 DIST dhcpcd-7.2.3.tar.xz 213552 BLAKE2B 5f89e11424b85702b05da6207ec346480c029de1416cc8892471de428ca0a4395a8915700e2237bfa2b133648973bc2a7c7d15aa2d0ba492f96fbf3908d7f613 SHA512 271cca422fad10eaf842acfd5b590c0ad537f5f23ee919a3928d8ad98463ab03bde21c0bc08741ea9618ee31095160a7c00066155eae2c74b17c49af65ba566f
 DIST dhcpcd-8.0.6.tar.xz 224552 BLAKE2B 5d0fab5977597ce182a2de56c8c4d085d3595a8f1209fc76788b707af0fffd4285a958cebfe7bab6c04ae7a2ba94c466d689dc9c3a71708c1baabd328b2bbf3e SHA512 19a568800a4e510a250de7cc111700b364c68bfe3907f1ac2cda81aacd079cb9ac87731cbabbf8f1e85e055a11c7ba88e419f6c4d7b33f8842dfaeadc7d1e193
-DIST dhcpcd-8.1.1.tar.xz 227088 BLAKE2B ab9ab5ec5ed969f79dd2092a1ab2dbc10b0f4c40afe8edaf67381b50fc34a9aee4ff264f4f50d439eed200d0273a1abed52875fe90cffcd0587d993220ef1d28 SHA512 2acca049029fa629ab6ba4f45959a2b67cf20c13e8659e71c1d5688fff5527df7007a4edfd9e88634ded9c76179d91b3e7adb92719f7a049d4f0cdbbd06e9a79
 DIST dhcpcd-8.1.2.tar.xz 228736 BLAKE2B 905829d2a0066729afa884f48049066e7fd802525f5ea436f02379845c848ac84b739394dfa90c1aebd74d87842b281121503815a31d05dcaa8b48c3026e357f SHA512 190e42391bc065536d0174a4a51db63b5e7360ccca3f69524a5c347d575ca9ee8439a739f88fadc1bb2509016d1d8f27fc7c7f2cc6724774f8072431f87b9bd7
diff --git a/net-misc/dhcpcd/dhcpcd-8.1.1.ebuild b/net-misc/dhcpcd/dhcpcd-8.1.1.ebuild
deleted file mode 100644 (file)
index 97babad..0000000
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit systemd toolchain-funcs
-
-if [[ ${PV} == "9999" ]]; then
-       inherit git-r3
-       EGIT_REPO_URI="https://roy.marples.name/git/dhcpcd.git"
-else
-       MY_P="${P/_alpha/-alpha}"
-       MY_P="${MY_P/_beta/-beta}"
-       MY_P="${MY_P/_rc/-rc}"
-       SRC_URI="https://roy.marples.name/downloads/${PN}/${MY_P}.tar.xz"
-       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
-       S="${WORKDIR}/${MY_P}"
-fi
-
-DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
-HOMEPAGE="https://roy.marples.name/projects/dhcpcd"
-LICENSE="BSD-2"
-SLOT="0"
-IUSE="elibc_glibc +embedded ipv6 kernel_linux +udev"
-
-COMMON_DEPEND="udev? ( virtual/udev )"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}"
-
-src_configure() {
-       local myeconfargs=(
-               --dbdir="${EPREFIX}/var/lib/dhcpcd"
-               --libexecdir="${EPREFIX}/lib/dhcpcd"
-               --localstatedir="${EPREFIX}/var"
-               --prefix="${EPREFIX}"
-               --with-hook=ntp.conf
-               $(use_enable embedded)
-               $(use_enable ipv6)
-               $(usex elibc_glibc '--with-hook=yp.conf' '')
-               $(usex kernel_linux '--rundir=${EPREFIX}/run' '')
-               $(usex udev '' '--without-dev --without-udev')
-               CC="$(tc-getCC)"
-       )
-       econf "${myeconfargs[@]}"
-}
-
-src_install() {
-       default
-       keepdir /var/lib/dhcpcd
-       newinitd "${FILESDIR}"/${PN}.initd ${PN}
-       systemd_dounit "${FILESDIR}"/${PN}.service
-}
-
-pkg_postinst() {
-       local dbdir="${EROOT}"/var/lib/dhcpcd old_files=()
-
-       local old_old_duid="${EROOT}"/var/lib/dhcpcd/dhcpcd.duid
-       local old_duid="${EROOT}"/etc/dhcpcd.duid
-       local new_duid="${dbdir}"/duid
-       if [[ -e "${old_old_duid}" ]] ; then
-               # Upgrade the duid file to the new format if needed
-               if ! grep -q '..:..:..:..:..:..' "${old_old_duid}"; then
-                       sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_old_duid}"
-               fi
-
-               # Move the duid to /etc, a more sensible location
-               if [[ ! -e "${old_duid}" ]] ; then
-                       cp -p "${old_old_duid}" "${new_duid}"
-               fi
-               old_files+=( "${old_old_duid}" )
-       fi
-
-       # dhcpcd-7 moves the files out of /etc
-       if [[ -e "${old_duid}" ]] ; then
-               if [[ ! -e "${new_duid}" ]] ; then
-                       cp -p "${old_duid}" "${new_duid}"
-               fi
-               old_files+=( "${old_duid}" )
-       fi
-       local old_secret="${EROOT}"/etc/dhcpcd.secret
-       local new_secret="${dbdir}"/secret
-       if [[ -e "${old_secret}" ]] ; then
-               if [[ ! -e "${new_secret}" ]] ; then
-                       cp -p "${old_secret}" "${new_secret}"
-               fi
-               old_files+=( "${old_secret}" )
-       fi
-
-       # dhcpcd-7 renames some files in /var/lib/dhcpcd
-       local old_rdm="${dbdir}"/dhcpcd-rdm.monotonic
-       local new_rdm="${dbdir}"/rdm_monotonic
-       if [[ -e "${old_rdm}" ]] ; then
-               if [[ ! -e "${new_rdm}" ]] ; then
-                       cp -p "${old_rdm}" "${new_rdm}"
-               fi
-               old_files+=( "${old_rdm}" )
-       fi
-       local lease=
-       for lease in "${dbdir}"/dhcpcd-*.lease*; do
-               [[ -f "${lease}" ]] || continue
-               old_files+=( "${lease}" )
-               local new_lease=$(basename "${lease}" | sed -e "s/dhcpcd-//")
-               [[ -e "${dbdir}/${new_lease}" ]] && continue
-               cp "${lease}" "${dbdir}/${new_lease}"
-       done
-
-       # Warn about removing stale files
-       if [[ -n "${old_files[@]}" ]] ; then
-               elog
-               elog "dhcpcd-7 has copied dhcpcd.duid and dhcpcd.secret from"
-               elog "${EROOT}/etc to ${dbdir}"
-               elog "and copied leases in ${dbdir} to new files with the dhcpcd-"
-               elog "prefix dropped."
-               elog
-               elog "You should remove these files if you don't plan on reverting"
-               elog "to an older version:"
-               local old_file=
-               for old_file in ${old_files[@]}; do
-                       elog "  ${old_file}"
-               done
-       fi
-
-       if [ -z "${REPLACING_VERSIONS}" ]; then
-               elog
-               elog "dhcpcd has zeroconf support active by default."
-               elog "This means it will always obtain an IP address even if no"
-               elog "DHCP server can be contacted, which will break any existing"
-               elog "failover support you may have configured in your net configuration."
-               elog "This behaviour can be controlled with the noipv4ll configuration"
-               elog "file option or the -L command line switch."
-               elog "See the dhcpcd and dhcpcd.conf man pages for more details."
-
-               elog
-               elog "Dhcpcd has duid enabled by default, and this may cause issues"
-               elog "with some dhcp servers. For more information, see"
-               elog "https://bugs.gentoo.org/show_bug.cgi?id=477356"
-       fi
-
-       if ! has_version net-dns/bind-tools; then
-               elog
-               elog "If you activate the lookup-hostname hook to look up your hostname"
-               elog "using the dns, you need to install net-dns/bind-tools."
-       fi
-}