dev-ros/rviz: Fix build of python bindings if rviz was not previously installed....
authorAlexis Ballier <aballier@gentoo.org>
Sat, 26 Sep 2015 09:50:01 +0000 (11:50 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Sat, 26 Sep 2015 09:50:14 +0000 (11:50 +0200)
Package-Manager: portage-2.2.22

dev-ros/rviz/files/libdir.patch [new file with mode: 0644]
dev-ros/rviz/rviz-1.11.9.ebuild

diff --git a/dev-ros/rviz/files/libdir.patch b/dev-ros/rviz/files/libdir.patch
new file mode 100644 (file)
index 0000000..9044ded
--- /dev/null
@@ -0,0 +1,26 @@
+https://github.com/ros-visualization/rviz/pull/922
+
+commit 2f93b132a63e25e3cece330ebaf16de7a8aa9517
+Author: Alexis Ballier <aballier@gentoo.org>
+Date:   Sat Sep 26 11:39:39 2015 +0200
+
+    python_bindings: sip: Use CATKIN_PACKAGE_LIB_DESTINATION instead of hardcoded lib.
+    
+    Fixes build with libdir != lib.
+    https://bugs.gentoo.org/show_bug.cgi?id=561480
+
+diff --git a/src/python_bindings/sip/CMakeLists.txt b/src/python_bindings/sip/CMakeLists.txt
+index 6b0c939..c91a6be 100644
+--- a/src/python_bindings/sip/CMakeLists.txt
++++ b/src/python_bindings/sip/CMakeLists.txt
+@@ -42,8 +42,8 @@ include(${python_qt_binding_EXTRAS_DIR}/sip_helper.cmake)
+ # maintain context for different named target
+ set(rviz_sip_INCLUDE_DIRS ${rviz_INCLUDE_DIRS} "${PROJECT_SOURCE_DIR}/src" ${catkin_INCLUDE_DIRS})
+ set(rviz_sip_LIBRARIES ${rviz_LIBRARIES} ${PROJECT_NAME})
+-set(rviz_sip_LIBRARY_DIRS ${rviz_LIBRARY_DIRS} ${CATKIN_DEVEL_PREFIX}/lib)
+-set(rviz_sip_LDFLAGS_OTHER ${rviz_LDFLAGS_OTHER} -Wl,-rpath,\\"${CATKIN_DEVEL_PREFIX}/lib\\")
++set(rviz_sip_LIBRARY_DIRS ${rviz_LIBRARY_DIRS} ${CATKIN_DEVEL_PREFIX}/${CATKIN_PACKAGE_LIB_DESTINATION})
++set(rviz_sip_LDFLAGS_OTHER ${rviz_LDFLAGS_OTHER} -Wl,-rpath,\\"${CATKIN_DEVEL_PREFIX}/${CATKIN_PACKAGE_LIB_DESTINATION}\\")
+ if(sip_helper_FOUND)
+   list(APPEND rviz_BINDINGS "sip")
index 0bb062de3654305a2fbf0631febd77303c8990a4..c801bb968c3292be26ea3c84d45dc7c87f85dcdb 100644 (file)
@@ -58,3 +58,5 @@ DEPEND="${RDEPEND}
                dev-ros/rostest[${PYTHON_USEDEP}]
                dev-cpp/gtest
        )"
+
+PATCHES=( "${FILESDIR}/libdir.patch" )