dev-perl/Array-Window: -r bump for EAPI7
authorKent Fredric <kentnl@gentoo.org>
Wed, 29 Apr 2020 08:43:28 +0000 (20:43 +1200)
committerKent Fredric <kentnl@gentoo.org>
Wed, 29 Apr 2020 08:44:15 +0000 (20:44 +1200)
- EAPI7
- Fix redundancy in DESCRIPTION
- Migrate Makefile.PL patching to patches instead of sed
- Strip unwanted tests

Package-Manager: Portage-2.3.97, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/Array-Window/Array-Window-1.20.0-r2.ebuild [new file with mode: 0644]
dev-perl/Array-Window/files/Array-Window-1.02-no-dot-inc.patch [new file with mode: 0644]

diff --git a/dev-perl/Array-Window/Array-Window-1.20.0-r2.ebuild b/dev-perl/Array-Window/Array-Window-1.20.0-r2.ebuild
new file mode 100644 (file)
index 0000000..c9ef755
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ADAMK
+DIST_VERSION=1.02
+inherit perl-module
+
+DESCRIPTION="Calculate windows/subsets/pages of arrays"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-perl/Params-Util-0.120.0
+"
+BDEPEND="${RDEPEND}
+       test? (
+               virtual/perl-Test-Simple
+       )
+"
+PATCHES=(
+       "${FILESDIR}/${PN}-1.02-no-dot-inc.patch"
+)
+PERL_RM_FILES=(
+       "t/97_meta.t"
+       "t/98_pod.t"
+       "t/99_pmv.t"
+)
diff --git a/dev-perl/Array-Window/files/Array-Window-1.02-no-dot-inc.patch b/dev-perl/Array-Window/files/Array-Window-1.02-no-dot-inc.patch
new file mode 100644 (file)
index 0000000..1ca661b
--- /dev/null
@@ -0,0 +1,21 @@
+From a611484135caeddcd28e65d6ee8f5794a6e8f982 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Wed, 29 Apr 2020 20:33:15 +1200
+Subject: Fix loading from inc/ on perl 5.28+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 67c6d3b..de84e50 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install 0.75;
+ all_from      'lib/Array/Window.pm';
+-- 
+2.26.2
+