net-p2p/bitcoind: Bump to 0.18.0
authorLuke Dashjr <luke-jr+git@utopios.org>
Mon, 20 May 2019 03:38:24 +0000 (03:38 +0000)
committerCraig Andrews <candrews@gentoo.org>
Wed, 7 Aug 2019 16:27:52 +0000 (12:27 -0400)
Closes: https://bugs.gentoo.org/685912

Signed-off-by: Luke Dashjr <luke-jr+git@utopios.org>
Signed-off-by: Craig Andrews <candrews@gentoo.org>
net-p2p/bitcoind/Manifest
net-p2p/bitcoind/bitcoind-0.18.0.ebuild [new file with mode: 0644]
net-p2p/bitcoind/files/0.18.0-daemon-fix.patch [new file with mode: 0644]
net-p2p/bitcoind/files/bitcoind-0.18.0-raii_event_tests-always.patch [new file with mode: 0644]

index c3a90d5a2b6a8350bfd9409683852354deb8e256..6498fdc5f9f24515b075da652532bb4499ad5b41 100644 (file)
@@ -1,4 +1,6 @@
 DIST bitcoin-0.16.3.knots20180918.patches.tar.xz 466344 BLAKE2B c45b96513e4b6317e6a2a55cc3b47302fbe56fb87717ae0197010694013331b5d071b85a11a73c76f08f39e9f0294d3475e89ee63272047df83893de4dbaa390 SHA512 2c3540acc668aeef4b8f01774219736d95395201ddeaccaf70e0bad4a89f05cdd5ffaf630bae0577656efb3580fae92ce0ee4bb1a720ea757ca59e3fd66e1893
 DIST bitcoin-0.17.1.knots20181229.patches.tar.xz 475988 BLAKE2B ce19ccbbeaac48f24b2833858a186494f84cb54ac380c42104f4d16b0a6acb44bc7a83c1b11311e2c566326d7067530ea5f34404def5f22b4825e2fa15aca22d SHA512 da89f9510ee523c712aa137512dda752ab8d115eb8a45a999aa742555621f557694db34162a1f6979922268a3e22563883ea6d9d9a47e5c7613235c0ff06fda0
+DIST bitcoin-0.18.0.knots20190502.patches.tar.xz 400252 BLAKE2B 0303bba89b3595a115ec8e5e743c362fc5feb0072ae493455cf3bcf1085b7f44d6b10142c05cb7ea59fadc630095de3a5f648007eb28f79551f2415db5c4f560 SHA512 b4c30c63cb6c770e04abd18e626db6e095b0d8b5aaf59e64b55eb8e19d4fdb559a3a2b939ab0e09967b4d3465b560e1379fa21b8efb3f25c22f84a2a1c655d16
 DIST bitcoin-v0.16.3.tar.gz 6658712 BLAKE2B 2c20b32ea30aed264115d1bd336b62fa28de69cbf116385508718efd7ff22537c3bd402c0965e0f6ddd8e79fc8b51f388f52f885847d36207a24523e927ca63e SHA512 2da25f56fe9b1f5a81815c14e70ff1a69ec15f742424e2c24d71303a71d57c8050dea5d5ba57425bbe0a01a3995ad9b30f0beea5dbafd1632a627cd3fd9a984d
 DIST bitcoin-v0.17.1.tar.gz 6224852 BLAKE2B efc86768ee2d23db83496ff9e62bc86d10c4d24a7343f4c706a4d336aeb94087b2d496db53e393beb5a9dc228bb9fe957ca89254c2fdaf9980b03029efbac2f8 SHA512 ef911ac6b49075a4f3d8db7f9f4dc59590d49847006fa36d7b8cce1634945d418accd95b12da505df38314fb7768f544863169d4b26b230e88dd627a83947466
+DIST bitcoin-v0.18.0.tar.gz 6533794 BLAKE2B 0eb7830e215757efb024be7aff73108c4a8e2f80a204ca71f1b3b6015933a1ab740ad006e58c473c4b9609b3e47885ba6564472a3514335ab6d7f99d32903822 SHA512 a2e38754d459fac0786eaa43f23c62ee326167f325d98964546217bcdc4f68ab88314bfb674ca4efd4cbc21fc3950bd029e1375ee101e0c72bbae7197fc31cf2
diff --git a/net-p2p/bitcoind/bitcoind-0.18.0.ebuild b/net-p2p/bitcoind/bitcoind-0.18.0.ebuild
new file mode 100644 (file)
index 0000000..813f809
--- /dev/null
@@ -0,0 +1,173 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DB_VER="4.8"
+inherit autotools bash-completion-r1 db-use systemd user
+
+BITCOINCORE_COMMITHASH="2472733a24a9364e4c6233ccd04166a26a68cc65"
+KNOTS_PV="${PV}.knots20190502"
+KNOTS_P="bitcoin-${KNOTS_PV}"
+
+DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
+HOMEPAGE="https://bitcoincore.org/ https://bitcoinknots.org/"
+SRC_URI="
+       https://github.com/bitcoin/bitcoin/archive/${BITCOINCORE_COMMITHASH}.tar.gz -> bitcoin-v${PV}.tar.gz
+       https://bitcoinknots.org/files/0.18.x/${KNOTS_PV}/${KNOTS_P}.patches.txz -> ${KNOTS_P}.patches.tar.xz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+asm +bitcoin_policy_rbf examples knots libressl +system-leveldb test upnp +wallet zeromq"
+
+DEPEND="
+       >=dev-libs/boost-1.52.0:=[threads(+)]
+       dev-libs/libevent:=
+       >=dev-libs/libsecp256k1-0.0.0_pre20151118:=[recovery]
+       >=dev-libs/univalue-1.0.4:=
+       system-leveldb? ( virtual/bitcoin-leveldb )
+       !libressl? ( dev-libs/openssl:0=[-bindist] )
+       libressl? ( dev-libs/libressl:0= )
+       upnp? ( >=net-libs/miniupnpc-1.9.20150916:= )
+       wallet? ( sys-libs/db:$(db_ver_to_slot "${DB_VER}")=[cxx] )
+       zeromq? ( net-libs/zeromq:= )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( doc/bips.md doc/bitcoin-conf.md doc/descriptors.md doc/files.md doc/JSON-RPC-interface.md doc/psbt.md doc/reduce-traffic.md doc/release-notes.md doc/REST-interface.md doc/tor.md )
+
+S="${WORKDIR}/bitcoin-${BITCOINCORE_COMMITHASH}"
+
+PATCHES=(
+       "${FILESDIR}/${P}-raii_event_tests-always.patch"
+)
+
+pkg_pretend() {
+       if use knots; then
+               elog "You are building ${PN} from Bitcoin Knots."
+               elog "For more information, see:"
+               elog "https://bitcoinknots.org/files/0.18.x/${KNOTS_PV}/${KNOTS_P}.desc.html"
+       else
+               elog "You are building ${PN} from Bitcoin Core."
+               elog "For more information, see:"
+               elog "https://bitcoincore.org/en/2019/05/02/release-${PV}/"
+       fi
+       if use bitcoin_policy_rbf; then
+               elog "Replace By Fee policy is enabled: Your node will preferentially mine and"
+               elog "relay transactions paying the highest fee, regardless of receive order."
+       else
+               elog "Replace By Fee policy is disabled: Your node will only accept the first"
+               elog "transaction seen consuming a conflicting input, regardless of fee"
+               elog "offered by later ones."
+       fi
+}
+
+pkg_setup() {
+       enewgroup bitcoin
+       enewuser bitcoin -1 -1 /var/lib/bitcoin bitcoin
+}
+
+src_prepare() {
+       sed -i 's/^\(complete -F _bitcoind bitcoind\) bitcoin-qt$/\1/' contrib/${PN}.bash-completion || die
+
+       local knots_patchdir="${WORKDIR}/${KNOTS_P}.patches/"
+
+       eapply "${knots_patchdir}/${KNOTS_P}.syslibs.patch"
+
+       if use knots; then
+               eapply "${knots_patchdir}/${KNOTS_P}.f.patch"
+               eapply "${knots_patchdir}/${KNOTS_P}.branding.patch"
+               eapply "${knots_patchdir}/${KNOTS_P}.ts.patch"
+               eapply "${FILESDIR}/${PV}-daemon-fix.patch"
+       fi
+
+       default
+
+       if ! use bitcoin_policy_rbf; then
+               sed -i 's/\(DEFAULT_ENABLE_REPLACEMENT = \)true/\1false/' src/validation.h || die
+       fi
+
+       echo '#!/bin/true' >share/genbuild.sh || die
+       mkdir -p src/obj || die
+       echo "#define BUILD_SUFFIX gentoo${PVR#${PV}}" >src/obj/build.h || die
+
+       eautoreconf
+       rm -r src/secp256k1 || die
+       if use system-leveldb; then
+               rm -r src/leveldb || die
+       fi
+}
+
+src_configure() {
+       local my_econf=(
+               $(use_enable asm)
+               --without-qtdbus
+               --without-qrencode
+               $(use_with upnp miniupnpc)
+               $(use_enable upnp upnp-default)
+               $(use_enable test tests)
+               $(use_enable wallet)
+               $(use_enable zeromq zmq)
+               --with-daemon
+               --disable-util-cli
+               --disable-util-tx
+               --disable-util-wallet
+               --disable-bench
+               --without-libs
+               --without-gui
+               --without-rapidcheck
+               --disable-fuzz
+               --disable-ccache
+               --disable-static
+               $(use_with system-leveldb)
+               --with-system-libsecp256k1
+               --with-system-univalue
+       )
+       econf "${my_econf[@]}"
+}
+
+src_install() {
+       default
+
+       rm -f "${ED%/}/usr/bin/test_bitcoin" || die
+
+       insinto /etc/bitcoin
+       newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
+       fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
+       fperms 600 /etc/bitcoin/bitcoin.conf
+
+       newconfd "contrib/init/bitcoind.openrcconf" ${PN}
+       newinitd "contrib/init/bitcoind.openrc" ${PN}
+       systemd_newunit "contrib/init/bitcoind.service" "bitcoind.service"
+
+       keepdir /var/lib/bitcoin/.bitcoin
+       fperms 700 /var/lib/bitcoin
+       fowners bitcoin:bitcoin /var/lib/bitcoin/
+       fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
+       dosym ../../../../etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
+
+       doman "${FILESDIR}/bitcoin.conf.5"
+
+       use zeromq && dodoc doc/zmq.md
+
+       newbashcomp contrib/${PN}.bash-completion ${PN}
+
+       if use examples; then
+               docinto examples
+               dodoc -r contrib/{linearize,qos}
+               use zeromq && dodoc -r contrib/zmq
+       fi
+
+       insinto /etc/logrotate.d
+       newins "${FILESDIR}/bitcoind.logrotate-r1" bitcoind
+}
+
+pkg_postinst() {
+       elog "To have ${PN} automatically use Tor when it's running, be sure your"
+       elog "'torrc' config file has 'ControlPort' and 'CookieAuthentication' setup"
+       elog "correctly, and:"
+       elog "- Using an init script: add the 'bitcoin' user to the 'tor' user group."
+       elog "- Running bitcoind directly: add that user to the 'tor' user group."
+}
diff --git a/net-p2p/bitcoind/files/0.18.0-daemon-fix.patch b/net-p2p/bitcoind/files/0.18.0-daemon-fix.patch
new file mode 100644 (file)
index 0000000..8a6737f
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/src/support/lockedpool.cpp
++++ b/src/support/lockedpool.cpp
+@@ -250,9 +250,6 @@ void *PosixLockedPageAllocator::AllocateLocked(size_t len, bool *lockingSuccess)
+     addr = mmap(nullptr, len, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0);
+     if (addr) {
+         *lockingSuccess = mlock(addr, len) == 0;
+-#ifdef MADV_DONTFORK
+-        madvise(addr, len, MADV_DONTFORK);
+-#endif
+ #ifdef MADV_DONTDUMP
+         madvise(addr, len, MADV_DONTDUMP);
+ #endif
diff --git a/net-p2p/bitcoind/files/bitcoind-0.18.0-raii_event_tests-always.patch b/net-p2p/bitcoind/files/bitcoind-0.18.0-raii_event_tests-always.patch
new file mode 100644 (file)
index 0000000..8148d56
--- /dev/null
@@ -0,0 +1,70 @@
+https://github.com/bitcoin/bitcoin/pull/16564
+
+From 272855746b18de76f51e84945d675904e9b907af Mon Sep 17 00:00:00 2001
+From: Craig Andrews <candrews@integralblue.com>
+Date: Wed, 7 Aug 2019 11:38:11 -0400
+Subject: [PATCH] Always define the raii_event_tests test suite
+
+The test suite must always be defined (even when EVENT_SET_MEM_FUNCTIONS_IMPLEMENTED is not defined) so that the test harness doesn't fail due to not being able to find the raii_event_tests test.
+
+This improves upon 95f97f4 actually fixing https://github.com/bitcoin/bitcoin/issues/9493
+---
+ src/test/raii_event_tests.cpp | 24 +++++++++++++++---------
+ 1 file changed, 15 insertions(+), 9 deletions(-)
+
+diff --git a/src/test/raii_event_tests.cpp b/src/test/raii_event_tests.cpp
+index bdb411d53f57..6691de882930 100644
+--- a/src/test/raii_event_tests.cpp
++++ b/src/test/raii_event_tests.cpp
+@@ -4,20 +4,28 @@
+ #include <event2/event.h>
++#include <test/test_bitcoin.h>
++
++#include <boost/test/unit_test.hpp>
++
++BOOST_FIXTURE_TEST_SUITE(raii_event_tests, BasicTestingSetup)
++
++#ifndef EVENT_SET_MEM_FUNCTIONS_IMPLEMENTED
++BOOST_AUTO_TEST_CASE(raii_event_creation)
++{
++    // dummy; do nothing
++}
++#endif  // EVENT_SET_MEM_FUNCTIONS_IMPLEMENTED
++
+ #ifdef EVENT_SET_MEM_FUNCTIONS_IMPLEMENTED
+-// It would probably be ideal to define dummy test(s) that report skipped, but boost::test doesn't seem to make that practical (at least not in versions available with common distros)
+ #include <map>
+ #include <stdlib.h>
+ #include <support/events.h>
+-#include <test/test_bitcoin.h>
+-
+ #include <vector>
+-#include <boost/test/unit_test.hpp>
+-
+ static std::map<void*, short> tags;
+ static std::map<void*, uint16_t> orders;
+ static uint16_t tagSequence = 0;
+@@ -36,8 +44,6 @@ static void tag_free(void* mem) {
+     free(mem);
+ }
+-BOOST_FIXTURE_TEST_SUITE(raii_event_tests, BasicTestingSetup)
+-
+ BOOST_AUTO_TEST_CASE(raii_event_creation)
+ {
+     event_set_mem_functions(tag_malloc, realloc, tag_free);
+@@ -89,6 +95,6 @@ BOOST_AUTO_TEST_CASE(raii_event_order)
+     event_set_mem_functions(malloc, realloc, free);
+ }
+-BOOST_AUTO_TEST_SUITE_END()
+-
+ #endif  // EVENT_SET_MEM_FUNCTIONS_IMPLEMENTED
++
++BOOST_AUTO_TEST_SUITE_END()