net-libs/signon-oauth2: Disable -Werror
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 24 Oct 2019 18:49:21 +0000 (20:49 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 24 Oct 2019 18:49:21 +0000 (20:49 +0200)
Closes: https://bugs.gentoo.org/698442
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
net-libs/signon-oauth2/signon-oauth2-0.24.ebuild

index 28d8ae826baa71801cd6509200f3df110d97bc31..ff53dc277ac84a18ce88ca551bc2e8e9f8864650 100644 (file)
@@ -8,7 +8,7 @@ MY_PV=VERSION_${PV}
 inherit qmake-utils
 
 DESCRIPTION="OAuth2 plugin for Signon daemon"
-HOMEPAGE="https://01.org/gsso/"
+HOMEPAGE="https://gitlab.com/accounts-sso/signon-plugin-oauth2"
 SRC_URI="https://gitlab.com/accounts-sso/${MY_PN}/-/archive/${MY_PV}/${MY_PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
 
 LICENSE="LGPL-2.1"
@@ -34,9 +34,11 @@ PATCHES=(
 
 src_prepare() {
        default
-
+       sed -i -e '/QMAKE_CXXFLAGS.*Werror/s/^/#DONT /' common-project-config.pri ||
+               die "failed to disable -Werror"
        if ! use test; then
-               sed -i -e '/^SUBDIRS/s/tests//' signon-oauth2.pro || die "Failed to disable tests"
+               sed -i -e '/^SUBDIRS/s/tests//' signon-oauth2.pro ||
+                       die "Failed to disable tests"
        fi
 }