Add patch to fix compilation with gcc-4.1 by Stephen Bridges <widget AT stdin DOT...
authorMark Loeser <halcy0n@gentoo.org>
Tue, 6 Jun 2006 03:36:50 +0000 (03:36 +0000)
committerMark Loeser <halcy0n@gentoo.org>
Tue, 6 Jun 2006 03:36:50 +0000 (03:36 +0000)
Package-Manager: portage-2.1_rc3-r2

media-plugins/mythgame/ChangeLog
media-plugins/mythgame/files/mythgame-0.19-gcc41.patch [new file with mode: 0644]
media-plugins/mythgame/mythgame-0.19.ebuild
media-plugins/mythphone/ChangeLog
media-plugins/mythphone/files/mythphone-0.19-gcc41.patch [new file with mode: 0644]
media-plugins/mythphone/mythphone-0.19.ebuild
media-plugins/mythvideo/ChangeLog
media-plugins/mythvideo/files/mythvideo-0.19-gcc41.patch [new file with mode: 0644]
media-plugins/mythvideo/mythvideo-0.19.ebuild

index 67b0be0d5f12e4872308e215d2062d5e5ad47008..622f548e46a7b91a013c6e2e109dfb83b846de94 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for media-plugins/mythgame
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/ChangeLog,v 1.31 2006/05/29 06:05:46 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/ChangeLog,v 1.32 2006/06/06 03:35:57 halcy0n Exp $
+
+  06 Jun 2006; Mark Loeser <halcy0n@gentoo.org>
+  +files/mythgame-0.19-gcc41.patch, mythgame-0.19.ebuild:
+  Add patch to fix compilation with gcc-4.1 by Stephen Bridges <widget AT
+  stdin DOT co DOT uk>; bug #132453
 
   29 May 2006; Doug Goldstein <cardoe@gentoo.org> -mythgame-0.18.1.ebuild:
   getting rid of old stuff
diff --git a/media-plugins/mythgame/files/mythgame-0.19-gcc41.patch b/media-plugins/mythgame/files/mythgame-0.19-gcc41.patch
new file mode 100644 (file)
index 0000000..f4e465b
--- /dev/null
@@ -0,0 +1,11 @@
+--- mythplugins-0.19/mythgame/mythgame/gamehandler.h.orig      2006-05-06 10:33:44.000000000 +0100
++++ mythplugins-0.19/mythgame/mythgame/gamehandler.h   2006-05-06 10:33:59.000000000 +0100
+@@ -106,7 +106,7 @@
+   protected:
+     static GameHandler* GetHandler(RomInfo *rominfo);
+-    static GameHandler* GameHandler::GetHandlerByName(QString systemname);
++    static GameHandler* GetHandlerByName(QString systemname);
+     bool rebuild;
+     int spandisks;
index d6b36904576c896ab41924381a630991e493be12..e434cb3aeec1718c50f945f7b56cf3110ce99ac1 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/mythgame-0.19.ebuild,v 1.2 2006/02/12 10:32:10 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/mythgame-0.19.ebuild,v 1.3 2006/06/06 03:35:57 halcy0n Exp $
 
-inherit mythtv-plugins
+inherit eutils mythtv-plugins
 
 DESCRIPTION="Game emulator module for MythTV."
 HOMEPAGE="http://www.mythtv.org/"
@@ -15,6 +15,11 @@ KEYWORDS="~amd64 ~ppc ~x86"
 RDEPEND="sys-libs/zlib"
 DEPEND="${RDEPEND}"
 
+src_unpack() {
+       mythtv-plugins_src_unpack
+       epatch "${FILESDIR}"/${P}-gcc41.patch
+}
+
 src_install () {
        mythtv-plugins_src_install || die "install failed"
 
index b485e5039425a31c69768bb1c906db9e0b249f71..145d2a5c7f289d9808597ef1075ccad2a01beba6 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for media-plugins/mythphone
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythphone/ChangeLog,v 1.12 2006/05/29 06:03:24 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythphone/ChangeLog,v 1.13 2006/06/06 03:36:27 halcy0n Exp $
+
+  06 Jun 2006; Mark Loeser <halcy0n@gentoo.org>
+  +files/mythphone-0.19-gcc41.patch, mythphone-0.19.ebuild:
+  Add patch to fix compilation with gcc-4.1 by Stephen Bridges <widget AT
+  stdin DOT co DOT uk>; bug #132453
 
   29 May 2006; Doug Goldstein <cardoe@gentoo.org> -mythphone-0.18.1.ebuild:
   getting rid of old stuff
diff --git a/media-plugins/mythphone/files/mythphone-0.19-gcc41.patch b/media-plugins/mythphone/files/mythphone-0.19-gcc41.patch
new file mode 100644 (file)
index 0000000..6246957
--- /dev/null
@@ -0,0 +1,22 @@
+--- mythplugins-0.19/mythphone/mythphone/sipfsm.orig.h 2006-05-06 15:00:23.000000000 +0100
++++ mythplugins-0.19/mythphone/mythphone/sipfsm.h      2006-05-06 15:00:58.000000000 +0100
+@@ -618,7 +618,7 @@
+     SipWatcher *CreateWatcherFsm(QString Url);
+     SipIM *CreateIMFsm(QString Url="", QString callIdStr="");
+     void StopWatchers();
+-    void SipFsm::KickWatcher(SipUrl *Url);
++    void KickWatcher(SipUrl *Url);
+     void SendIM(QString destUrl, QString CallId, QString imMsg);
+     int numCalls();
+     int getPrimaryCall() { return primaryCall; };
+--- mythplugins-0.19/mythphone/mythphone/vxml.orig.h   2006-05-06 15:01:16.000000000 +0100
++++ mythplugins-0.19/mythphone/mythphone/vxml.h        2006-05-06 15:01:33.000000000 +0100
+@@ -10,7 +10,7 @@
+ {
+   public:
+     vxmlVariable(QString N, QString V);             
+-    vxmlVariable::vxmlVariable(QString N, short *wav, int S);
++    vxmlVariable(QString N, short *wav, int S);
+     virtual ~vxmlVariable() {}; 
+     bool isType(QString t) { return (t == Type); };
+     QString getName() { return Name; };
index 1ab2b52b7dfa09a9352f31298cd1fd965b9ed5f1..2cfee2c9426eeaa6bc7c6267509767e4e97d5967 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythphone/mythphone-0.19.ebuild,v 1.1 2006/02/12 10:36:17 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythphone/mythphone-0.19.ebuild,v 1.2 2006/06/06 03:36:27 halcy0n Exp $
 
-inherit mythtv-plugins
+inherit eutils mythtv-plugins
 
 DESCRIPTION="Phone and video calls with SIP."
 HOMEPAGE="http://www.mythtv.org/"
@@ -16,3 +16,8 @@ RDEPEND="festival? ( app-accessibility/festival )"
 DEPEND="${DEPEND}"
 
 MTVCONF=$(use_enable festival)
+
+src_unpack() {
+       mythtv-plugins_src_unpack
+       epatch "${FILESDIR}"/${P}-gcc41.patch
+}
index 6416380cce1488ff20b95f7a56c3b4393d756622..8f4c6ad0755797defc986c8a3e46774f160df9a0 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for media-plugins/mythvideo
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/ChangeLog,v 1.34 2006/05/29 06:01:32 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/ChangeLog,v 1.35 2006/06/06 03:36:50 halcy0n Exp $
+
+  06 Jun 2006; Mark Loeser <halcy0n@gentoo.org>
+  +files/mythvideo-0.19-gcc41.patch, mythvideo-0.19.ebuild:
+  Add patch to fix compilation with gcc-4.1 by Stephen Bridges <widget AT
+  stdin DOT co DOT uk>; bug #132453
 
   29 May 2006; Doug Goldstein <cardoe@gentoo.org> -mythvideo-0.18.1.ebuild,
   mythvideo-0.19.ebuild:
diff --git a/media-plugins/mythvideo/files/mythvideo-0.19-gcc41.patch b/media-plugins/mythvideo/files/mythvideo-0.19-gcc41.patch
new file mode 100644 (file)
index 0000000..8a393f5
--- /dev/null
@@ -0,0 +1,22 @@
+--- mythplugins-0.19/mythvideo/mythvideo/videoselected.h.orig  2006-05-06 10:42:17.000000000 +0100
++++ mythplugins-0.19/mythvideo/mythvideo/videoselected.h       2006-05-06 10:42:32.000000000 +0100
+@@ -35,7 +35,7 @@
+     VideoSelected(VideoList *lvideolist,
+                  MythMainWindow *parent, const char *name = 0, int index = 0);
+     ~VideoSelected();
+-    void VideoSelected::processEvents() { qApp->processEvents(); }
++    void processEvents() { qApp->processEvents(); }
+     
+   protected slots:
+--- mythplugins-0.19/mythvideo/mythvideo/videomanager.h.orig   2006-05-06 10:38:53.000000000 +0100
++++ mythplugins-0.19/mythvideo/mythvideo/videomanager.h        2006-05-06 10:39:23.000000000 +0100
+@@ -30,7 +30,7 @@
+   public:
+     VideoManager(MythMainWindow *parent, const char *name = 0);
+     ~VideoManager(void);
+-    void VideoManager::processEvents() { qApp->processEvents(); }
++    void processEvents() { qApp->processEvents(); }
+     
+   public slots:
+     void slotManualIMDB();
index 58c0ade7a4d9d0fcf8257052cdc33d954e8f3a94..fb19d54c564e02ddde8d066c56a02c88ac351141 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/mythvideo-0.19.ebuild,v 1.3 2006/05/29 06:01:32 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/mythvideo-0.19.ebuild,v 1.4 2006/06/06 03:36:50 halcy0n Exp $
 
-inherit mythtv-plugins
+inherit eutils mythtv-plugins
 
 DESCRIPTION="Video player module for MythTV."
 HOMEPAGE="http://www.mythtv.org/"
@@ -18,3 +18,8 @@ RDEPEND="dev-perl/libwww-perl
        dev-perl/XML-Simple
        media-video/mplayer"
 DEPEND="${RDEPEND}"
+
+src_unpack() {
+       mythtv-plugins_src_unpack
+       epatch "${FILESDIR}"/${P}-gcc41.patch
+}