x11-wm/mutter: refresh patchset for some crash fixes and more
authorMart Raudsepp <leio@gentoo.org>
Sun, 5 May 2019 09:42:02 +0000 (12:42 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 5 May 2019 10:10:13 +0000 (13:10 +0300)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
x11-wm/mutter/Manifest
x11-wm/mutter/mutter-3.30.2-r1.ebuild [new file with mode: 0644]

index d22dacf44b31b64a08295a19ae915f71fb46e3c8..2c6053c53c5d87d5eb784ee8d3601011d8bcfc76 100644 (file)
@@ -2,4 +2,5 @@ DIST mutter-3.24.4.tar.xz 3583916 BLAKE2B 86a9e16ed96270713e400ccb4dc64b91c26312
 DIST mutter-3.26.2-patchset.tar.xz 48156 BLAKE2B 7b33495a8bb7ac69f5610e1dfcb1fef49a983403fd176b229a75bcc7691e83e76a3dd87b7663ece0fcdc4077becd3ffa5e33217584f156456813769646730bf9 SHA512 2eeb9dfe137d6ea65f957ed19aa5ef83106aa16a049531c0c41d3ab6afac6c1b345cc68f2a9a9c41658172cc0dde61b946e6bf2507979ff4155e79770adf5e90
 DIST mutter-3.26.2.tar.xz 3622904 BLAKE2B b32af24c6ffcd0e6af38ab1ff7cd0ba16ea3ceb84c62ed21d9e38fff5357eda2648050beada3fc8727474407a419a2c218331c8a87f7eb68eddf824d26ca9c51 SHA512 95885b4c053d4bc467a7c11615ee3d1a3086a674ae10e7cb9bb241f692e66dd8190508db1cdf1760bc2f19100e532e68d5e147d344e94d1430d80dd26ca0156b
 DIST mutter-3.30.2-patchset.tar.xz 9968 BLAKE2B 7b664f35eec3cb6f298d5628bc7c0dd9697076f4fcfca431d08581d2c3054fbad952802a3279b174f207b5c6fdea2f29811352c7b2b1119e87bf689c1cbc8ce1 SHA512 949acecf66cf9060527c2a3559f831cfbe9ed68007ae2ca94df920c8691bc28d5577d15fe1bd9c2fddef978b23b29d4e6dfef16c232a96fd5006ed844321b957
+DIST mutter-3.30.2-r1-patchset.tar.xz 14096 BLAKE2B 83f2e975a4404b878e832a70fe7a84a2a39d291dc1f6191e5805633327d21fb0796b8b0172a35602bec9c7e879819ebdb189f324cba3f4a4aee232d5e439ba0a SHA512 f842920d6855803b8712e1736399805ecd3266a61dd7baba1f80383978d00533e34fd742103b578f9f2969ab2059f9e0c7b3812d2ea2283b6ffa91810bf6094f
 DIST mutter-3.30.2.tar.xz 3725692 BLAKE2B 280b7a6319e5d4705baee965936df6f31ba8ca96ce3812cf640578c6817aaa82b6ff8fde7b2740ecd8edb6c4746f4608f997772a24d67f12fcb0c5c77fc9b29a SHA512 3890270b7eb4b8753274d30ad26693b829a69b31f36501845c59b000deb174be58b5167f6754767dba02ebc44688697fbe7344a327879a073955047b69333a2e
diff --git a/x11-wm/mutter/mutter-3.30.2-r1.ebuild b/x11-wm/mutter/mutter-3.30.2-r1.ebuild
new file mode 100644 (file)
index 0000000..67f779d
--- /dev/null
@@ -0,0 +1,147 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_EAUTORECONF="yes"
+inherit gnome2 virtualx
+
+DESCRIPTION="GNOME 3 compositing window manager based on Clutter"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/mutter/"
+SRC_URI+=" https://dev.gentoo.org/~leio/distfiles/${PF}-patchset.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0/3" # 0/libmutter_api_version - ONLY gnome-shell (or anything using mutter-clutter-<api_version>.pc) should use the subslot
+
+IUSE="debug elogind gles2 input_devices_wacom +introspection systemd test udev wayland"
+# native backend requires gles3 for hybrid graphics blitting support and a logind provider
+REQUIRED_USE="
+       wayland? ( ^^ ( elogind systemd ) )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# libXi-1.7.4 or newer needed per:
+# https://bugzilla.gnome.org/show_bug.cgi?id=738944
+# gl.pc package is required, which is only installed by mesa if glx is enabled; pre-emptively requiring USE=X on mesa, as hopefully eventually it'll support disabling glx for wayland-only systems
+RDEPEND="
+       >=dev-libs/atk-2.5.3
+       >=x11-libs/gdk-pixbuf-2:2
+       >=dev-libs/json-glib-0.12.0
+       >=x11-libs/pango-1.30[introspection?]
+       >=x11-libs/cairo-1.14[X]
+       >=x11-libs/gtk+-3.19.8:3[X,introspection?]
+       >=dev-libs/glib-2.53.2:2
+       >=media-libs/libcanberra-0.26[gtk3]
+       >=x11-libs/startup-notification-0.7
+       >=x11-libs/libXcomposite-0.2
+       >=gnome-base/gsettings-desktop-schemas-3.21.4[introspection?]
+       gnome-base/gnome-desktop:3=
+
+       x11-libs/libICE
+       x11-libs/libSM
+       x11-libs/libX11
+       >=x11-libs/libXcomposite-0.4
+       x11-libs/libXcursor
+       x11-libs/libXdamage
+       x11-libs/libXext
+       >=x11-libs/libXfixes-3
+       >=x11-libs/libXi-1.7.4
+       x11-libs/libXinerama
+       >=x11-libs/libXrandr-1.5
+       x11-libs/libXrender
+       x11-libs/libxcb
+       x11-libs/libxkbfile
+       >=x11-libs/libxkbcommon-0.4.3[X]
+       x11-misc/xkeyboard-config
+
+       gnome-extra/zenity
+       media-libs/mesa[X(+),egl,gles2?]
+
+       input_devices_wacom? ( >=dev-libs/libwacom-0.13 )
+       introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+       udev? ( >=virtual/libgudev-232:= )
+       wayland? (
+               >=dev-libs/libinput-1.4
+               >=dev-libs/wayland-1.13.0
+               >=dev-libs/wayland-protocols-1.16
+               >=media-libs/mesa-10.3[egl,gbm,wayland,gles2]
+               systemd? ( sys-apps/systemd )
+               elogind? ( sys-auth/elogind )
+               >=virtual/libgudev-232:=
+               >=virtual/libudev-136:=
+               x11-base/xorg-server[wayland]
+               x11-libs/libdrm:=
+       )
+"
+DEPEND="${RDEPEND}
+       dev-util/glib-utils
+       >=sys-devel/gettext-0.19.6
+       virtual/pkgconfig
+       x11-base/xorg-proto
+       test? ( app-text/docbook-xml-dtd:4.5 )
+       wayland? ( >=sys-kernel/linux-headers-4.4 )
+"
+
+PATCHES=(
+       # Some patches from gnome-3-30 branch on top of 3.30.2
+       "${WORKDIR}"/patches/
+       # Hack to not fail USE="-wayland,-gles2" builds with no mesa[gles2]
+       "${FILESDIR}"/3.28.3-no-gles2-fix.patch # requires eautoreconf
+)
+
+src_prepare() {
+       # Disable building of noinst_PROGRAM for tests
+       if ! use test; then
+               sed -e '/^noinst_PROGRAMS/d' \
+                       -i cogl/tests/conform/Makefile.{am,in} || die
+               sed -e '/noinst_PROGRAMS += testboxes/d' \
+                       -i src/Makefile-tests.am || die
+               sed -e '/noinst_PROGRAMS/ s/testboxes$(EXEEXT)//' \
+                       -i src/Makefile.in || die
+       fi
+
+       gnome2_src_prepare
+
+       # Leave the damn CFLAGS alone
+       sed -e 's/$CFLAGS -g/$CFLAGS /' \
+               -i clutter/configure || die
+       sed -e 's/$CFLAGS -g -O0/$CFLAGS /' \
+               -i cogl/configure || die
+       sed -e 's/$CFLAGS -g -O/$CFLAGS /' \
+               -i configure || die
+}
+
+src_configure() {
+       # TODO: pipewire remote desktop support; --disable-remote-desktop actually enables it due to upstream autotools bug in 3.26.2 (omitted means disabled)
+       # TODO: nvidia EGLDevice support
+       # TODO: elogind vs systemd is automagic in 3.28.3 - if elogind is found, it's used instead of systemd; but not a huge problem as elogind package blocks systemd package
+       # TODO: lack of --with-xwayland-grab-default-access-rules relies on default settings, but in Gentoo we might have some more packages we want to give Xgrab access (mostly virtual managers and remote desktops)
+       # Prefer gl driver by default
+       # GLX is forced by mutter but optional in clutter
+       # xlib-egl-platform required by mutter x11 backend
+       # native backend without wayland is useless
+       gnome2_src_configure \
+               --disable-static \
+               --enable-compile-warnings=minimum \
+               --enable-gl \
+               --enable-glx \
+               --enable-sm \
+               --enable-startup-notification \
+               --enable-verbose-mode \
+               --enable-xlib-egl-platform \
+               --with-default-driver=gl \
+               --with-libcanberra \
+               $(usex debug --enable-debug=yes "") \
+               $(use_enable gles2)        \
+               $(use_enable gles2 cogl-gles2) \
+               $(use_enable introspection) \
+               $(use_enable wayland) \
+               $(use_enable wayland kms-egl-platform) \
+               $(use_enable wayland native-backend) \
+               $(use_enable wayland wayland-egl-server) \
+               $(use_with input_devices_wacom libwacom) \
+               $(use_with udev gudev)
+}
+
+src_test() {
+       virtx emake check
+}