sys-devel/lld: Use BDEPEND semi-properly
authorMichał Górny <mgorny@gentoo.org>
Tue, 17 Sep 2019 21:00:16 +0000 (23:00 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 17 Sep 2019 21:00:50 +0000 (23:00 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-devel/lld/lld-10.0.0.9999.ebuild
sys-devel/lld/lld-9.0.0.9999.ebuild

index 89abb313a97059e3072079fc43d15fb1bc7d2ced..2469a9bd70468f3fad1ea6eae5a3a621392e4361 100644 (file)
@@ -23,14 +23,14 @@ IUSE="test"
 RESTRICT="!test? ( test )"
 
 RDEPEND="~sys-devel/llvm-${PV}"
-DEPEND="${RDEPEND}
-       test? ( $(python_gen_any_dep "~dev-python/lit-${PV}[\${PYTHON_USEDEP}]") )"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( $(python_gen_any_dep "~dev-python/lit-${PV}[\${PYTHON_USEDEP}]") )"
 
 # least intrusive of all
 CMAKE_BUILD_TYPE=RelWithDebInfo
 
 python_check_deps() {
-       has_version "dev-python/lit[${PYTHON_USEDEP}]"
+       has_version -b "dev-python/lit[${PYTHON_USEDEP}]"
 }
 
 pkg_setup() {
index 216166a79aff8c284eeae4802532932db0313ddc..6935200f15c691ad3845d9b5dc1ef55901e0de77 100644 (file)
@@ -24,14 +24,14 @@ IUSE="test"
 RESTRICT="!test? ( test )"
 
 RDEPEND="~sys-devel/llvm-${PV}"
-DEPEND="${RDEPEND}
-       test? ( $(python_gen_any_dep "~dev-python/lit-${PV}[\${PYTHON_USEDEP}]") )"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( $(python_gen_any_dep "~dev-python/lit-${PV}[\${PYTHON_USEDEP}]") )"
 
 # least intrusive of all
 CMAKE_BUILD_TYPE=RelWithDebInfo
 
 python_check_deps() {
-       has_version "dev-python/lit[${PYTHON_USEDEP}]"
+       has_version -b "dev-python/lit[${PYTHON_USEDEP}]"
 }
 
 pkg_setup() {