dev-python/rfc3986: Version Bump
authorJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 10:46:20 +0000 (12:46 +0200)
committerJustin Lecher <jlec@gentoo.org>
Wed, 2 Sep 2015 11:05:33 +0000 (13:05 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/rfc3986/Manifest
dev-python/rfc3986/rfc3986-0.2.2.ebuild [new file with mode: 0644]

index b084e29d3194f2f871618a4fd4d5c478a4aa6f4e..c4886689af501d99feafa3f2b95a9ee635709197 100644 (file)
@@ -1 +1,2 @@
 DIST rfc3986-0.2.0.tar.gz 14522 SHA256 8a7b3f6cfdfb969c2e876513e87c30ebe1e4bdc9fae4a63c701eee88bbec9b22 SHA512 e16a7b690597e1d3bce0869e1bd7aecb60926b61da38e8b7170d920d73130512d4017426461d755792c2ea691b5c01ae8955e0b9818679e795b7338794b66d83 WHIRLPOOL 03bc5ca0d5e2cc06f8bc68029dfccfa71820512b546caeaddfe66f2233a9346d4ae3123c69efaee2b90258acdb3f0cde8f2ee84f4f29c0e1375f4fb9fc56effa
+DIST rfc3986-0.2.2.tar.gz 17250 SHA256 b66238ee937485509326e0280eab4d8193df0e640936b99a6a181374dff97f7b SHA512 d6df82bce5de487a43cfd0e875d9e746e02f051fdfffa7b07564d025e77ed53ad02a09a837ba6c971b81019e091c694819de0e4ce43f19b4aa764ba21f70c054 WHIRLPOOL fc5b53681be16642947fa709232dc06e5643ddce6309bddb899abbdcac508060a84918f9b4b3b324c6de30dbd14669b92dea5ec34f39ddfb7a1289a7cf95a9ce
diff --git a/dev-python/rfc3986/rfc3986-0.2.2.ebuild b/dev-python/rfc3986/rfc3986-0.2.2.ebuild
new file mode 100644 (file)
index 0000000..3099989
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Validating URI References per RFC 3986"
+HOMEPAGE="http://tools.ietf.org/html/rfc3986 https://github.com/sigmavirus24/rfc3986 https://rfc3986.rtfd.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_test() {
+       py.test || die
+}