dev-libs/folks: bump to 0.12.1
authorMart Raudsepp <leio@gentoo.org>
Sat, 7 Sep 2019 19:38:16 +0000 (22:38 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sat, 7 Sep 2019 22:08:53 +0000 (01:08 +0300)
Closes: https://bugs.gentoo.org/690544
Package-Manager: Portage-2.3.69, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
dev-libs/folks/Manifest
dev-libs/folks/files/0.12.1-conditional-tests.patch [new file with mode: 0644]
dev-libs/folks/files/0.12.1-no-tracker-tests.patch [new file with mode: 0644]
dev-libs/folks/folks-0.12.1.ebuild [new file with mode: 0644]

index d362ae2148b23df4ac010b264a30555a46b89ccc..a14a94a5d969954507f8a1e652c15474b8b64392 100644 (file)
@@ -1 +1,2 @@
 DIST folks-0.11.4.tar.xz 1972272 BLAKE2B 69fa21f9baf34a3597f8a7e3f789ab3d03ad508ec74e0e1dfaa8df09865cb99748483b4fa4aa9c219803c512a49a23e95d4c3ded5b285b0a0d2f7416a1d9bf7f SHA512 bd4088322c34b5d6e633d7d5d83dfb61eb3499014adf6fecad27231ec63509401b2867186d019a2f7c92cc3b3f2e6cfbc80e0d4700d84ce7a08d8153af3d2392
+DIST folks-0.12.1.tar.xz 522688 BLAKE2B 584957b628e286b850ee45c3f79d942ae602124e0130eeddc8806ae6fc12accd26c140df5caa0a1a68c84bff707df785d863d2f69ee9a0b6b450b8159c21fb39 SHA512 f60e993508137b33602ccc814bde45ad780d61afb0566f8175fd01b3dcaa5f5771e11d98156c4ecfd85f920a7adc140a5b2582eaaa97568b8fb3b3761668decb
diff --git a/dev-libs/folks/files/0.12.1-conditional-tests.patch b/dev-libs/folks/files/0.12.1-conditional-tests.patch
new file mode 100644 (file)
index 0000000..cde0847
--- /dev/null
@@ -0,0 +1,40 @@
+From 93c03b9582eb1eac21f084decf86ca5f1340dc53 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sat, 7 Sep 2019 22:16:43 +0300
+Subject: [PATCH] meson: Allow disabling build of tests
+
+---
+ meson.build       | 4 +++-
+ meson_options.txt | 1 +
+ 2 files changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 91800654..37e6b5c2 100644
+--- a/meson.build
++++ b/meson.build
+@@ -219,7 +219,9 @@ subdir('tools')
+ subdir('po')
+ # Tests
+-subdir('tests')
++if get_option('test')
++  subdir('tests')
++endif
+ if docs_enabled
+   subdir('docs')
+diff --git a/meson_options.txt b/meson_options.txt
+index 042a72e8..b4552d49 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -9,6 +9,7 @@ option('zeitgeist', type: 'boolean', value: false, description: 'build Zeitgeist
+ option('import_tool', type: 'boolean', value: true, description: 'Enable building the meta-contact import tool')
+ option('inspect_tool', type: 'boolean', value: true, description: 'Enable building the data inspection tool')
+ # Test options
++option('test', type: 'boolean', value: true, description: 'Build test programs')
+ option('installed_tests', type: 'boolean', value: false, description: 'Install test programs')
+ # Docs
+ option('docs', type: 'boolean', value: false, description: 'Enable documentation generation')
+-- 
+2.20.1
+
diff --git a/dev-libs/folks/files/0.12.1-no-tracker-tests.patch b/dev-libs/folks/files/0.12.1-no-tracker-tests.patch
new file mode 100644 (file)
index 0000000..3dbfadf
--- /dev/null
@@ -0,0 +1,26 @@
+From b2b0832cf69560bdf0692d275d49d4ed6e293426 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sat, 7 Sep 2019 22:26:38 +0300
+Subject: [PATCH] tests: disable failing tracker tests
+
+All tracker tests fail for me, so disable them for now to at least
+continue testing the rest.
+---
+ tests/meson.build | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/tests/meson.build b/tests/meson.build
+index 6a7fa29c..2079051b 100644
+--- a/tests/meson.build
++++ b/tests/meson.build
+@@ -43,7 +43,3 @@ endif
+ if eds_backend_enabled
+   subdir('eds')
+ endif
+-
+-if tracker_backend_enabled
+-  subdir('tracker')
+-endif
+-- 
+2.20.1
+
diff --git a/dev-libs/folks/folks-0.12.1.ebuild b/dev-libs/folks/folks-0.12.1.ebuild
new file mode 100644 (file)
index 0000000..0809549
--- /dev/null
@@ -0,0 +1,88 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+VALA_MAX_API_VERSION="0.44" # tests-utils fails to build with newer with v0.12.1
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Library for aggregating people from multiple sources"
+HOMEPAGE="https://wiki.gnome.org/Projects/Folks"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/25" # subslot = libfolks soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+
+IUSE="bluetooth eds +telepathy test tracker utils"
+REQUIRED_USE="bluetooth? ( eds )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+       $(vala_depend)
+       >=dev-libs/glib-2.44:2
+       dev-libs/dbus-glib
+       >=dev-libs/libgee-0.10:0.8[introspection]
+       >=dev-libs/gobject-introspection-1.54:=
+       telepathy? ( >=net-libs/telepathy-glib-0.19.9[vala] )
+       tracker? ( app-misc/tracker:0/2.0 )
+       eds? ( >=gnome-extra/evolution-data-server-3.13.90:=[vala] )
+       dev-libs/libxml2:2
+       utils? ( sys-libs/readline:0= )
+"
+# telepathy-mission-control needed at runtime; it is used by the telepathy
+# backend via telepathy-glib's AccountManager binding.
+RDEPEND="${DEPEND}
+       bluetooth? ( >=net-wireless/bluez-5[obex] )
+       telepathy? ( net-im/telepathy-mission-control )
+"
+BDEPEND="
+       >=dev-util/meson-0.49
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+"
+
+# FIXME:
+# test? ( bluetooth? ( dbusmock is missing in the tree ) )
+DEPEND="${COMMON_DEPEND}
+       test? ( sys-apps/dbus
+               bluetooth? ( dev-python/dbusmock ) )
+"
+
+PATCHES=(
+       "${FILESDIR}"/${PV}-conditional-tests.patch # Allow not building lots of test executables when tests are disabled
+       "${FILESDIR}"/${PV}-no-tracker-tests.patch # TODO: Tracker tests fail; this removed them for now
+)
+
+src_prepare() {
+       vala_src_prepare
+       xdg_src_prepare
+}
+
+src_configure() {
+       local emesonargs=(
+               $(meson_use bluetooth bluez_backend)
+               $(meson_use eds eds_backend)
+               -Dlibsocialweb_backend=false # not packaged
+               $(meson_use eds ofono_backend)
+               $(meson_use telepathy telepathy_backend)
+               $(meson_use tracker tracker_backend)
+               -Dzeitgeist=false # last rited package
+               -Dimport_tool=true
+               $(meson_use utils inspect_tool)
+               $(meson_use test)
+               -Dinstalled_tests=false
+               -Ddocs=false # Needs find_program sedding to specific version; only dev docs, don't bother
+       )
+       meson_src_configure
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_schemas_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_schemas_update
+}