sys-apps/ifd-gempc: cleanup
authorAlon Bar-Lev <alonbl@gentoo.org>
Fri, 3 Feb 2017 23:05:11 +0000 (01:05 +0200)
committerAlon Bar-Lev <alonbl@gentoo.org>
Sat, 4 Feb 2017 01:30:47 +0000 (03:30 +0200)
Package-Manager: portage-2.3.3

sys-apps/ifd-gempc/Manifest
sys-apps/ifd-gempc/ifd-gempc-1.0.6.ebuild [deleted file]

index ee59b4bf31f2ab7fc9d3364b229abc8491191e41..d135cdf69889e0599cf0f566d9d6917f4f35cf01 100644 (file)
@@ -1,2 +1 @@
-DIST ifd-gempc-1.0.6.tar.gz 76156 SHA256 29f772aed8f0dfaf65c1f539338c728344af2cf50aca6b5652ed4afca65d3da3 SHA512 3e27bb117569dfaea457cc4ff5cad59bb2f6666cd25ed5958003f7f6e1e3693bc8b148ed6aa2e462ee18d620ae670b8486c95826577eb53e83931574a9921e05 WHIRLPOOL b6c2be8670d2746f429a21254a09510de8c3574b4c20283c07bd22a3bb1aa306d59f41b5f972431aff5c99bbea2e061670bb9d401ed802358ed13dd8c53805af
 DIST ifd-gempc-1.0.7.tar.gz 76712 SHA256 604e4bb8cc015dcc4099f0317d11ac2ae3550648966844243a296652c8639028 SHA512 dde143bd2ca46cca91f979ddbb300f0b5fea37ecfa0c67058d887fcd56edf58adecce85dd05c7af25329fdfcfdf5bf7a52d4dc24061231a234180aad3df44a93 WHIRLPOOL 4dd8572457b910a2c25bb1d132cd1d2716984a339715584ec7bed982c84eb9fea81f0a0b8e944ef252a88bcd31a72a71f4eaa214b2536c3f09de75f0e428c5ff
diff --git a/sys-apps/ifd-gempc/ifd-gempc-1.0.6.ebuild b/sys-apps/ifd-gempc/ifd-gempc-1.0.6.ebuild
deleted file mode 100644 (file)
index 3fabcb8..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit toolchain-funcs
-
-DESCRIPTION="GemCore based PC/SC reader drivers for pcsc-lite"
-HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/ifd-GemPC"
-LICENSE="GPL-2 BSD"
-KEYWORDS="~amd64 ~ppc ~x86"
-SLOT="0"
-SRC_URI="http://ludovic.rousseau.free.fr/softwares/ifd-GemPC/${P}.tar.gz"
-IUSE=""
-RDEPEND=">=sys-apps/pcsc-lite-1.2.9_beta7
-       =virtual/libusb-0*"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig"
-
-src_compile() {
-       emake CC="$(tc-getCC)" || die "emake failed"
-}
-
-src_install () {
-       local pcscdir="$(pkg-config --variable=usbdropdir libpcsclite)"
-       local conf="/etc/reader.conf.d/${PN}.conf"
-       emake CC="$(tc-getCC)" DESTDIR="${D}" install || die "emake install failed"
-       dodoc README*
-       dodir "$(dirname "${conf}")"
-       insinto "$(dirname "${conf}")"
-       newins "${FILESDIR}/reader.conf" "$(basename "${conf}")"
-       sed -e "s:%PCSC_DRIVERS_DIR%:${pcscdir}:g" -e "s:%libGemPC410%:libGemPC410.so.${PV}:g" -i "${D}${conf}"
-}
-
-pkg_postinst() {
-       elog "NOTICE:"
-       elog "1. If you are using GemPC410, modify ${conf}"
-       elog "2. Run update-reader.conf, yes this is a command..."
-       elog "3. Restart pcscd"
-}
-
-pkg_postrm() {
-       #
-       # Without this, pcscd will not start next time.
-       #
-       local conf="/etc/reader.conf.d/${PN}.conf"
-       if ! [[ -f "${conf}" && -f "$(grep LIBPATH "${conf}" | sed 's/LIBPATH *//' | sed 's/ *$//g' | head -n 1)" ]]; then
-               [[ -f "${conf}" ]] && rm "${conf}"
-               update-reader.conf
-               elog "NOTICE:"
-               elog "You need to restart pcscd"
-       fi
-}