dev-python/werkzeug: Bump to 1.0.0, add missing deps
authorMichał Górny <mgorny@gentoo.org>
Fri, 7 Feb 2020 06:16:16 +0000 (07:16 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 7 Feb 2020 07:15:07 +0000 (08:15 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/werkzeug/Manifest
dev-python/werkzeug/werkzeug-1.0.0.ebuild [new file with mode: 0644]

index 4b12ca74c7201bfb652e2028eef2739cd42b5cfc..17d41acaa6a2368043b682ba872afe15d04d35a9 100644 (file)
@@ -4,3 +4,4 @@ DIST Werkzeug-0.15.4.tar.gz 925334 BLAKE2B ffb132026e5a43bdbbb6decf19c47b07bb38a
 DIST Werkzeug-0.15.5.tar.gz 926570 BLAKE2B 39d68f7ea2f99ffa60f5a2af7ebf8a01e68a83e32106abd8fcbba3a5402bf6c6c02f7bb9b84cd483aa061bb065a0f2f6d809db55a2f6950996d70cf62a620520 SHA512 e2980b649db0c246fa87b94972f1a1e00b19f20a90e34733267cb50b0d1c8e83701f4bde3e466f9f12243c47b3cc40c6977e63164f18ee5e518b75e952988edd
 DIST werkzeug-0.16.0.gh.tar.gz 939220 BLAKE2B 08f77bfbb8703b25be00dba018e9aea16cb4a6977ff3906f636fe24b4e16662f7777584839c8e153532f32a0551281a6fb28bf618da5d5e6c42cdc6e8b391162 SHA512 78e7d2ccceb8764f92a3252b2ff670065a42fe2ad1d2b4631e05c107d2128f8f6f4090e32bd975526e4b5985dbbdbac22e9ad1514d14e88ecfb064483107d0ed
 DIST werkzeug-0.16.1.gh.tar.gz 937876 BLAKE2B e5f962e9cab4a06a6f2d63ac35df896ed764377b458ccdc744800ffa5d2d456a836f0a7c4aef08b750b95904e955ce3b0241102d48bd28080e91fe29823e789e SHA512 52611b2e22b8af6b643471ca1df6e6f262067ef8882363768f21d9b0ee837aedd192c358a3a41788b2036d6c6cc0156043f1f5b8f6a04b2a701790b66837a62e
+DIST werkzeug-1.0.0.gh.tar.gz 907492 BLAKE2B b81a3645d1228a7a2321f14d9093f77ac2cb620403008efb09b5f22b5b27297972d86adc307249828eda6dd2ca38a17ba1590cfc6ff47e7c8faddb34ffa0ba7a SHA512 bc6d61b078aebd92d79a68d2b040dc9cf0cb5a61fe9732861109324bd7f7be6e5fb9e2101f145429909d0e06a6435bd3b8d707022525c5236ba52776a315af2e
diff --git a/dev-python/werkzeug/werkzeug-1.0.0.ebuild b/dev-python/werkzeug/werkzeug-1.0.0.ebuild
new file mode 100644 (file)
index 0000000..10841a9
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="Werkzeug"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="http://werkzeug.pocoo.org/ https://pypi.org/project/Werkzeug/ https://github.com/pallets/werkzeug"
+#SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+SRC_URI="https://github.com/pallets/werkzeug/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
+DEPEND="
+       test? (
+               dev-python/click[${PYTHON_USEDEP}]
+               dev-python/cryptography[${PYTHON_USEDEP}]
+               dev-python/requests[${PYTHON_USEDEP}]
+               dev-python/pytest-timeout[${PYTHON_USEDEP}]
+               dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+       )"
+
+distutils_enable_tests pytest
+
+python_test() {
+       pytest -vv -p no:httpbin || die "Tests fail with ${EPYTHON}"
+}