dev-util/spirv-tools: Fix python dependency
authorNick Sarnie <sarnex@gentoo.org>
Sat, 15 Jun 2019 23:40:14 +0000 (19:40 -0400)
committerNick Sarnie <sarnex@gentoo.org>
Sat, 15 Jun 2019 23:40:14 +0000 (19:40 -0400)
Fixes: https://bugs.gentoo.org/688136
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
dev-util/spirv-tools/spirv-tools-2019.1-r2.ebuild [new file with mode: 0644]
dev-util/spirv-tools/spirv-tools-9999.ebuild

diff --git a/dev-util/spirv-tools/spirv-tools-2019.1-r2.ebuild b/dev-util/spirv-tools/spirv-tools-2019.1-r2.ebuild
new file mode 100644 (file)
index 0000000..57c340b
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit cmake-multilib cmake-utils python-any-r1
+
+DESCRIPTION="Provides an API and commands for processing SPIR-V modules"
+HOMEPAGE="https://github.com/KhronosGroup/SPIRV-Tools"
+SRC_URI="https://github.com/KhronosGroup/SPIRV-Tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Tests fail upon finding symbols that do not match a regular expression
+# in the generated library. Easily hit with non-standard compiler flags
+RESTRICT="test"
+
+DEPEND=""
+RDEPEND=""
+BDEPEND="${PYTHON_DEPS}
+       >=dev-util/spirv-headers-1.3.4_pre20190302"
+
+EGIT_COMMIT="2297d4a3dfcbfd2a8b4312fab055ae26e3289fd3"
+S="${WORKDIR}/SPIRV-Tools-${PV}"
+PATCHES=( "${FILESDIR}"/${PN}-2019.1-Fix-vertex-instrumentation.patch )
+
+multilib_src_configure() {
+       local mycmakeargs=(
+               "-DSPIRV-Headers_SOURCE_DIR=/usr/"
+               "-DSPIRV_WERROR=OFF"
+       )
+
+       cmake-utils_src_configure
+}
+
+multilib_src_install() {
+       cmake-utils_src_install
+       echo "${EGIT_COMMIT}" > "${PN}-commit.h" || die
+       insinto /usr/include/"${PN}"
+       doins  "${PN}-commit.h"
+}
index 1df290d2083c9ca49bb2a61b9e472bc48e97c1c9..07ff87f02689572fc6bf1ac885aed6502bf89fdf 100644 (file)
@@ -1,7 +1,8 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
 
 inherit cmake-multilib cmake-utils git-r3
 
@@ -16,8 +17,10 @@ SLOT="0"
 # in the generated library. Easily hit with non-standard compiler flags
 RESTRICT="test"
 
+DEPEND=""
 RDEPEND=""
-DEPEND=">=dev-util/spirv-headers-1.3.4_pre20190302"
+BDEPEND="${PYTHON_DEPS}
+       >=dev-util/spirv-headers-1.3.4_pre20190302"
 
 multilib_src_configure() {
        local mycmakeargs=(