Version bump (bug #146076). Dropped old versions.
authorTiziano Müller <dev-zero@gentoo.org>
Fri, 29 Dec 2006 12:59:59 +0000 (12:59 +0000)
committerTiziano Müller <dev-zero@gentoo.org>
Fri, 29 Dec 2006 12:59:59 +0000 (12:59 +0000)
Package-Manager: portage-2.1.2_rc4-r1

net-ftp/ftpcube/ChangeLog
net-ftp/ftpcube/files/digest-ftpcube-0.5.0_beta1 [new file with mode: 0644]
net-ftp/ftpcube/files/ftpcube-0.5.0_beta1-transports.patch [new file with mode: 0644]
net-ftp/ftpcube/ftpcube-0.5.0_beta1.ebuild [new file with mode: 0644]

index 3e9e6a3d8316da463b1d80aadc66a59953b32e8f..e69e60131d7f690334dee9c6b168b47598213eb4 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for net-ftp/ftpcube
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpcube/ChangeLog,v 1.29 2005/07/26 12:59:32 dholm Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpcube/ChangeLog,v 1.30 2006/12/29 12:59:59 dev-zero Exp $
+
+*ftpcube-0.5.0_beta1 (29 Dec 2006)
+
+  29 Dec 2006; Tiziano Müller <dev-zero@gentoo.org>
+  +files/ftpcube-0.5.0_beta1-transports.patch, -ftpcube-0.4.0.ebuild,
+  -ftpcube-0.4.1.ebuild, -ftpcube-0.4.2.ebuild, -ftpcube-0.4.3.ebuild,
+  +ftpcube-0.5.0_beta1.ebuild:
+  Version bump (bug #146076). Dropped old versions.
 
   26 Jul 2005; David Holm <dholm@gentoo.org> ftpcube-0.4.3-r1.ebuild:
   Added to ~ppc.
diff --git a/net-ftp/ftpcube/files/digest-ftpcube-0.5.0_beta1 b/net-ftp/ftpcube/files/digest-ftpcube-0.5.0_beta1
new file mode 100644 (file)
index 0000000..96bfef7
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 bbed56e99970d2e77435fa679e7ee0e8 ftpcube-0.5.0-b1.tar.gz 137058
+RMD160 19f99218ac6003e464a736c015a2f24993884684 ftpcube-0.5.0-b1.tar.gz 137058
+SHA256 3e5659c01ee650fb43131403780128c82e16a968c9c550df2a4cb9d8657cdbd2 ftpcube-0.5.0-b1.tar.gz 137058
diff --git a/net-ftp/ftpcube/files/ftpcube-0.5.0_beta1-transports.patch b/net-ftp/ftpcube/files/ftpcube-0.5.0_beta1-transports.patch
new file mode 100644 (file)
index 0000000..bdb738c
--- /dev/null
@@ -0,0 +1,11 @@
+--- setup.py.orig      2006-12-29 13:39:51.000000000 +0100
++++ setup.py   2006-12-29 13:40:05.000000000 +0100
+@@ -40,7 +40,7 @@
+ _data_files.extend (_locales)
+ # Generate package list
+-_packages = [ 'libftpcube', 'libftpcube/archtypes', 'libftpcube/icons' ]
++_packages = [ 'libftpcube', 'libftpcube/archtypes', 'libftpcube/icons', 'libftpcube/transports' ]
+ if sys.platform == "win32":
+       _ftpcube_script = "ftpcube.pyw"
diff --git a/net-ftp/ftpcube/ftpcube-0.5.0_beta1.ebuild b/net-ftp/ftpcube/ftpcube-0.5.0_beta1.ebuild
new file mode 100644 (file)
index 0000000..c1c39b6
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpcube/ftpcube-0.5.0_beta1.ebuild,v 1.1 2006/12/29 12:59:59 dev-zero Exp $
+
+inherit distutils eutils
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+MY_P=${P/_beta/-b}
+
+DESCRIPTION="Graphical FTP client using wxPython"
+SRC_URI="mirror://sourceforge/ftpcube/${MY_P}.tar.gz"
+HOMEPAGE="http://ftpcube.sourceforge.net/"
+SLOT="0"
+LICENSE="Artistic"
+IUSE="sftp"
+
+DEPEND=">=dev-python/wxpython-2.6.3.3
+       sftp? ( dev-python/paramiko )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       epatch "${FILESDIR}/${P}-transports.patch"
+}
+
+src_install() {
+       distutils_src_install --install-scripts=/usr/bin
+}