dev-python/pyfltk: Drop old
authorJustin Lecher <jlec@gentoo.org>
Wed, 23 Sep 2015 13:00:58 +0000 (15:00 +0200)
committerJustin Lecher <jlec@gentoo.org>
Wed, 23 Sep 2015 13:04:30 +0000 (15:04 +0200)
Package-Manager: portage-2.2.21
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/pyfltk/pyfltk-1.3.0-r1.ebuild [deleted file]

diff --git a/dev-python/pyfltk/pyfltk-1.3.0-r1.ebuild b/dev-python/pyfltk/pyfltk-1.3.0-r1.ebuild
deleted file mode 100644 (file)
index 6cbe1a8..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-# FIXME: MakeSwig.py execution should be made work from pyfltk-1.1.5.ebuild
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 flag-o-matic
-
-MY_P=pyFltk-${PV}
-
-DESCRIPTION="Python interface to Fltk library"
-HOMEPAGE="http://pyfltk.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm ppc ppc64 x86"
-IUSE="doc"
-
-DEPEND=">=x11-libs/fltk-1.3.0:1[opengl]"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-python_prepare_all() {
-       local PATCHES=(
-               "${FILESDIR}"/${P}-linux-3.x-detection.patch
-       )
-
-       # Disable installation of documentation and tests.
-       sed -i -e '/package_data=/d' setup.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
-       append-flags -fno-strict-aliasing
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( fltk/docs/. )
-       distutils-r1_python_install_all
-}