app-emacs/bbdb: Remove old.
authorUlrich Müller <ulm@gentoo.org>
Wed, 28 Aug 2019 10:08:59 +0000 (12:08 +0200)
committerUlrich Müller <ulm@gentoo.org>
Wed, 28 Aug 2019 10:18:36 +0000 (12:18 +0200)
Package-Manager: Portage-2.3.73, Repoman-2.3.17
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-emacs/bbdb/Manifest
app-emacs/bbdb/bbdb-2.35-r1.ebuild [deleted file]
app-emacs/bbdb/files/50bbdb-gentoo.el [deleted file]

index 2bf9a8ec1b6d9d6092250b64fd7008e8c9d1da81..5c00f00f1fcda9f1b8153187c75de1aaf5ca2feb 100644 (file)
@@ -1,4 +1 @@
-DIST bbdb-2.35.tar.gz 393097 BLAKE2B 194924e828cb02022e90b49bc1c1cf8cfa23146e3118dbf6be7310930463c743f1648d54daf5f605f8d7a83ea307974084cbc07d630ae2273e8147a05dced799 SHA512 ee815f62796bcda63d37ae5a3805d065f6cc79648ca86852b97d4c1b849a1eb6c8f46dab2f257b9a8f9efc44d38469739f98137037c10f79f37a1ff235f6a413
 DIST bbdb-3.1.2.tar.gz 378935 BLAKE2B 3fc862d2d68632c997e3f250aa82cced743c3cc3861c74789bb12015ab99745270c79722dc0342334b90f4dd9071ef809ab670a342ac227c24a927870907c25c SHA512 8b32baadc4eb06b0abf533ccb1f540f4f407f27b8d2e847ae25e62d1405e1de5cfc6af16368eecd4086f281ee7a4016cf25568847b3cb798156c7e18e1912576
-DIST dates.el 7048 BLAKE2B 866a9a7a5524290a7762d0ad3c7b91766ca61fa025c2f634ce11909fdbd2a6d8bd7316ec66649590148a92660ef6122c93bac8085f333f1e319cc740349a8e90 SHA512 51b0dca58a1b54e913a0dbd97df12230ec49f05b368404fa3d49cddf4ca8e14dbff47a28087c4ba41b189a38a3608c77454e102ae5bb124d07d1ad3ec9c39e71
-DIST point-at.el 440 BLAKE2B fba28258d84c378985d2f17e28f0258e1e671f831f726e1d1289e84e246d9965300aa303c7f7dd383c9d33ec84e1e8bb014bba1e4f737661a5522a37ce6541ad SHA512 e38cbf39cb3f29f51f6759a7ba548f065c4763668d38c746eb69d9ab2384357f6b1c7f032a6afe739bc64658f5863730b7a4b3023cc9df1cc5e088e591c02760
diff --git a/app-emacs/bbdb/bbdb-2.35-r1.ebuild b/app-emacs/bbdb/bbdb-2.35-r1.ebuild
deleted file mode 100644 (file)
index f603c56..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit elisp
-
-DESCRIPTION="The Insidious Big Brother Database"
-HOMEPAGE="http://bbdb.sourceforge.net/"
-SRC_URI="http://bbdb.sourceforge.net/${P}.tar.gz
-       http://www.mit.edu/afs/athena/contrib/emacs-contrib/Fin/point-at.el
-       http://www.mit.edu/afs/athena/contrib/emacs-contrib/Fin/dates.el"
-
-LICENSE="GPL-2+ Texinfo-manual"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
-IUSE="tex"
-
-RDEPEND="tex? ( virtual/tex-base )"
-
-SITEFILE="50${PN}-gentoo.el"
-TEXMF="/usr/share/texmf-site"
-
-src_prepare() {
-       sed -i -e '0,/^--- bbdb-mail-folders.el ---$/d;/^--- end ---$/,$d' \
-               bits/bbdb-mail-folders.el || die "sed failed"
-       sed -i -e '/^;/,$!d' bits/bbdb-sort-mailrc.el || die "sed failed"
-       cp "${DISTDIR}"/{dates,point-at}.el bits || die "cp failed"
-}
-
-src_configure() {
-       default
-}
-
-src_compile() {
-       emake -j1
-       BYTECOMPFLAGS="-L bits -L lisp" elisp-compile bits/*.el || die
-}
-
-src_install() {
-       elisp-install ${PN} lisp/*.el{,c} || die
-       elisp-install ${PN}/bits bits/*.el{,c} || die
-       elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
-       doinfo texinfo/*.info*
-       dodoc ChangeLog INSTALL README bits/*.txt
-       newdoc bits/README README.bits
-       if use tex; then
-               insinto "${TEXMF}"/tex/plain/bbdb
-               doins tex/*.tex
-       fi
-}
-
-pkg_postinst() {
-       elisp-site-regen
-       use tex && texconfig rehash
-
-       elog "If you use encryption or signing, you may specify the encryption"
-       elog "method by customising variable \"bbdb/pgp-method\". For details,"
-       elog "see the documentation of this variable. Depending on the Emacs"
-       elog "version, installation of additional packages like app-emacs/gnus"
-       elog "or app-emacs/mailcrypt may be required."
-}
-
-pkg_postrm() {
-       elisp-site-regen
-       use tex && texconfig rehash
-}
diff --git a/app-emacs/bbdb/files/50bbdb-gentoo.el b/app-emacs/bbdb/files/50bbdb-gentoo.el
deleted file mode 100644 (file)
index 7953b3c..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-(add-to-list 'load-path "@SITELISP@")
-(add-to-list 'load-path "@SITELISP@/bits")
-(require 'bbdb)
-(bbdb-initialize)