media-libs/flac: switch to CPU_FLAGS_PPC
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Sat, 4 Apr 2020 23:57:34 +0000 (16:57 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Sun, 5 Apr 2020 00:12:03 +0000 (17:12 -0700)
--enable-altivec prevented flac from compiling on G4/G5
due to misdetection of vsx
Adding proper flag allows to compile with altivec but without vsx.

Closes: https://bugs.gentoo.org/701308
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
media-libs/flac/flac-1.3.3.ebuild

index b3aea9e2746ae3d367da776a0e8dea98086d7ab0..0a616c50a7d7804dfb28a06ae4a8ab042c027ee6 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI="https://downloads.xiph.org/releases/${PN}/${P}.tar.xz"
 LICENSE="BSD FDL-1.2 GPL-2 LGPL-2.1"
 SLOT="0"
 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="altivec +cxx debug ogg cpu_flags_x86_sse static-libs"
+IUSE="+cxx debug ogg cpu_flags_ppc_altivec cpu_flags_ppc_vsx cpu_flags_x86_sse static-libs"
 
 RDEPEND="ogg? ( >=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}] )"
 DEPEND="${RDEPEND}
@@ -30,7 +30,8 @@ multilib_src_configure() {
                --disable-examples
                --disable-xmms-plugin
                $([[ ${CHOST} == *-darwin* ]] && echo "--disable-asm-optimizations")
-               $(use_enable altivec)
+               $(use_enable cpu_flags_ppc_altivec altivec)
+               $(use_enable cpu_flags_ppc_vsx vsx)
                $(use_enable cpu_flags_x86_sse sse)
                $(use_enable cxx cpplibs)
                $(use_enable debug)