media-libs/lv2-1.16.0: partially fixed doc building
authorMiroslav Šulc <fordfrog@gentoo.org>
Sat, 14 Dec 2019 19:15:12 +0000 (20:15 +0100)
committerMiroslav Šulc <fordfrog@gentoo.org>
Sat, 14 Dec 2019 19:15:32 +0000 (20:15 +0100)
added patch to support python3

Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
media-libs/lv2/files/lv2-1.16.0-python3.patch [new file with mode: 0644]
media-libs/lv2/lv2-1.16.0.ebuild

diff --git a/media-libs/lv2/files/lv2-1.16.0-python3.patch b/media-libs/lv2/files/lv2-1.16.0-python3.patch
new file mode 100644 (file)
index 0000000..330fc4c
--- /dev/null
@@ -0,0 +1,22 @@
+diff --git a/lv2specgen/lv2specgen.py b/lv2specgen/lv2specgen.py
+index ddd0ba5..224ace8 100755
+--- a/lv2specgen/lv2specgen.py
++++ b/lv2specgen/lv2specgen.py
+@@ -329,7 +329,7 @@ def getComment(m, urinode, classlist, proplist, instalist):
+         if have_lxml:
+             try:
+                 # Parse and validate documentation as XHTML Basic 1.1
+-                doc = """<?xml version="1.0" encoding="UTF-8"?>
++                doc = """<?xml version="1.0"?>
+ <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML Basic 1.1//EN"
+                       "DTD/xhtml-basic11.dtd">
+ <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en">
+@@ -340,7 +340,7 @@ def getComment(m, urinode, classlist, proplist, instalist):
+ %s
+   </body>
+ </html>
+-""" % str(markup.decode())
++""" % str(markup)
+                 oldcwd = os.getcwd()
+                 os.chdir(specgendir)
index 2dc4fcf3dd6088582c544b7d616a9149d05dd403..9284873bc1ffeaa07d15335d7bcc829de0e86ab5 100644 (file)
@@ -35,6 +35,10 @@ RDEPEND="
 "
 DOCS=( "README.md" "NEWS" )
 
+PATCHES=(
+       "${FILESDIR}/${P}-python3.patch"
+)
+
 src_prepare() {
        default
        multilib_copy_sources