dev-python/ipython: Break circular dependency with dev-python/qtconsole
authorJustin Lecher <jlec@gentoo.org>
Wed, 2 Mar 2016 20:11:41 +0000 (20:11 +0000)
committerJustin Lecher <jlec@gentoo.org>
Wed, 2 Mar 2016 20:44:39 +0000 (20:44 +0000)
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=576088

Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/ipython/ipython-4.1.1.ebuild

index 3934c31c2cc816a0e315aac1c39a40732700a76d..41d72d7bb602183580435fc1fae8403b2f0cbb9b 100644 (file)
@@ -38,8 +38,7 @@ RDEPEND="${CDEPEND}
                dev-python/notebook[${PYTHON_USEDEP}]
                dev-python/ipywidgets[${PYTHON_USEDEP}]
        )
-       nbconvert? ( dev-python/nbconvert[${PYTHON_USEDEP}] )
-       qt4? ( dev-python/qtconsole )"
+       nbconvert? ( dev-python/nbconvert[${PYTHON_USEDEP}] )"
 DEPEND="${CDEPEND}
        >=dev-python/setuptools-18.5[${PYTHON_USEDEP}]
        test? (
@@ -66,6 +65,7 @@ DEPEND="${CDEPEND}
        )"
 
 PDEPEND="
+       qt4? ( dev-python/qtconsole )
        smp? ( dev-python/ipyparallel[${PYTHON_USEDEP}] )"
 
 PATCHES=(