app-vim/vim-latex: remove old
authorTim Harder <radhermit@gentoo.org>
Mon, 19 Mar 2018 05:40:35 +0000 (01:40 -0400)
committerTim Harder <radhermit@gentoo.org>
Mon, 19 Mar 2018 05:41:48 +0000 (01:41 -0400)
app-vim/vim-latex/Manifest
app-vim/vim-latex/metadata.xml
app-vim/vim-latex/vim-latex-1.8.23.20141116.ebuild [deleted file]
app-vim/vim-latex/vim-latex-1.9.0.ebuild [deleted file]

index 68ef2890a65976b5f0acab606fd58d96e209e655..2442ec0c4ed7143b73f0e4e636882351bbac7825 100644 (file)
@@ -1,3 +1 @@
 DIST vim-latex-1.10.0.tar.gz 260820 BLAKE2B 2314ad5ded3bea51def3172e8f2b7a7483839b58804f9d8c1cc1c8f1139c1da731f91525691d47dba57d07a7db85c371e87c5ce0d3d22a004a9402df7e7cad3a SHA512 1d22b675c124e402a280dcc3a675b49a92fb9f4d42efdda0ea97be26379cd6c023589a35e165f4231524d853380e22411901bfbcc98f171c938ba800821a1213
-DIST vim-latex-1.8.23-20141116.812-gitd0f31c9.tar.gz 288376 BLAKE2B e9853e3c86764147401f9ad6909f216864f97b9b35ca84839c7047555a52ad51d9488930a820a275b27331cc8a52360c1ce0550fe93d2d6efce8873ba1214572 SHA512 18444b7aef9ca1d7288e2616c0329274172afa3f932096fddc5e40888f65c8cacae2454ab316c5699395268aa88af13b32f3ae6e36058e27e4e48e6d6591b762
-DIST vim-latex-1.9.0.tar.gz 289271 BLAKE2B 1372fb590d9f3726de51439c4110911c8404dedbf17a0d8d651fcea34fba3d1622440a90b5974a1d45eafec5d079c8b84fb0665b0203bbf5df75a10caa0161df SHA512 4cce21683af74a5a1034e5ecc0f6268b5065324908671d40b4d6b60ac880890df1e9c3d6c16fa57dd1edc33766ded374fd43473699a974ba83e4aeac42030e63
index 6c05a86c762dcdb982713a9d49e3c57a76d12d69..20ffb74c87d21633e39f27678c4dac914dacfbae 100644 (file)
@@ -5,9 +5,6 @@
                <email>vim@gentoo.org</email>
                <name>Gentoo Vim Project</name>
        </maintainer>
-       <use>
-               <flag name="html">Install HTML documentation</flag>
-       </use>
        <upstream>
                <remote-id type="sourceforge">vim-latex</remote-id>
        </upstream>
diff --git a/app-vim/vim-latex/vim-latex-1.8.23.20141116.ebuild b/app-vim/vim-latex/vim-latex-1.8.23.20141116.ebuild
deleted file mode 100644 (file)
index da767f6..0000000
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit vim-plugin versionator python-single-r1 eutils
-
-MY_REV="812-gitd0f31c9"
-MY_P="${PN}-$( replace_version_separator 3 - ).${MY_REV}"
-
-DESCRIPTION="A comprehensive set of tools to view, edit and compile LaTeX documents"
-HOMEPAGE="http://vim-latex.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="vim"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
-IUSE="html"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
-       ${PYTHON_DEPS}
-       || (
-               app-editors/vim[python,${PYTHON_USEDEP}]
-               app-editors/gvim[python,${PYTHON_USEDEP}]
-       )
-       virtual/latex-base
-       !app-vim/vimtex"
-
-S=${WORKDIR}/${MY_P}
-
-VIM_PLUGIN_HELPFILES="latex-suite.txt latex-suite-quickstart.txt latexhelp.txt imaps.txt"
-
-src_prepare() {
-       # The makefiles do weird stuff, including running the svn command
-       rm Makefile Makefile.in || die "rm Makefile Makefile.in failed"
-
-       epatch_user
-}
-
-src_install() {
-       use html && dohtml -r doc/
-
-       # Don't mess up vim's doc dir with random files
-       mv doc mydoc || die
-       mkdir doc || die
-       mv mydoc/*.txt doc/ || die
-       rm -rf mydoc || die
-
-       # Don't install buggy tags scripts, use ctags instead
-       rm latextags ltags || die
-
-       vim-plugin_src_install
-
-       # Use executable permissions (bug #352403)
-       fperms a+x /usr/share/vim/vimfiles/ftplugin/latex-suite/outline.py
-
-       python_fix_shebang "${ED}"
-}
-
-pkg_postinst() {
-       vim-plugin_pkg_postinst
-
-       if [[ -z ${REPLACING_VERSIONS} ]]; then
-               echo
-               elog "To use the vim-latex plugin add:"
-               elog "   filetype plugin on"
-               elog '   set grepprg=grep\ -nH\ $*'
-               elog "   let g:tex_flavor='latex'"
-               elog "to your ~/.vimrc-file"
-               echo
-       fi
-}
diff --git a/app-vim/vim-latex/vim-latex-1.9.0.ebuild b/app-vim/vim-latex/vim-latex-1.9.0.ebuild
deleted file mode 100644 (file)
index f8c5370..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit vim-plugin python-single-r1
-
-DESCRIPTION="A comprehensive set of tools to view, edit and compile LaTeX documents"
-HOMEPAGE="http://vim-latex.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="vim"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
-       ${PYTHON_DEPS}
-       || (
-               app-editors/vim[python,${PYTHON_USEDEP}]
-               app-editors/gvim[python,${PYTHON_USEDEP}]
-       )
-       virtual/latex-base
-       !app-vim/vimtex"
-
-VIM_PLUGIN_HELPFILES="latex-suite.txt latex-suite-quickstart.txt latexhelp.txt imaps.txt"
-
-src_compile() { :; }
-
-src_install() {
-       # remove unused metadata
-       rm vim-latex.metainfo.xml || die
-
-       # don't mess up vim's doc dir with random files
-       mv doc mydoc || die
-       mkdir doc || die
-       mv mydoc/*.txt doc/ || die
-       rm -rf mydoc || die
-
-       # don't install buggy tags scripts, use ctags instead
-       rm latextags ltags || die
-
-       vim-plugin_src_install
-
-       # use executable permissions (bug #352403)
-       fperms a+x /usr/share/vim/vimfiles/ftplugin/latex-suite/outline.py
-
-       python_fix_shebang "${ED}"
-}
-
-pkg_postinst() {
-       vim-plugin_pkg_postinst
-
-       if [[ -z ${REPLACING_VERSIONS} ]]; then
-               echo
-               elog "To use the vim-latex plugin add:"
-               elog "   filetype plugin on"
-               elog '   set grepprg=grep\ -nH\ $*'
-               elog "   let g:tex_flavor='latex'"
-               elog "to your ~/.vimrc-file"
-               echo
-       fi
-}