sys-power/powertop: Use tarballs from github
authorMatt Turner <mattst88@gentoo.org>
Sun, 23 Feb 2020 17:53:38 +0000 (09:53 -0800)
committerMatt Turner <mattst88@gentoo.org>
Sun, 23 Feb 2020 17:55:23 +0000 (09:55 -0800)
The 2.11 tarball has a bizarre name, and we have to run eautoreconf
anyway.

Signed-off-by: Matt Turner <mattst88@gentoo.org>
sys-power/powertop/powertop-9999.ebuild

index 165318e3ddd14af1f4ca9ceaf52b8bc2225442de..bf3642c77e9ba345b730de11d539e4f7afd937f5 100644 (file)
@@ -9,10 +9,8 @@ if [[ ${PV} == "9999" ]] ; then
        GIT_ECLASS="git-r3"
        SRC_URI=""
 else
-       SRC_URI="https://01.org/sites/default/files/downloads/${PN}-v${PV}.tar.gz"
+       SRC_URI="https://github.com/fenrus75/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
        KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
-       MY_P="${PN}-v${PV}"
-       S="${WORKDIR}/${MY_P}"
 fi
 
 inherit autotools ${GIT_ECLASS} linux-info
@@ -104,10 +102,8 @@ src_prepare() {
        # Bug 599114
        sed -i '1s|^|AX_REQUIRE_DEFINED([AX_CXX_COMPILE_STDCXX_11])|' configure.ac || die
 
-       if [[ ${PV} == "9999" ]] ; then
-               chmod +x scripts/version || die "Failed to make 'scripts/version' executable"
-               scripts/version || die "Failed to extract version information"
-       fi
+       chmod +x scripts/version || die "Failed to make 'scripts/version' executable"
+       scripts/version || die "Failed to extract version information"
 
        eautoreconf
 }