gnome-extra/gnome-dvb-daemon: added version 0.2.90
authorDennis Lamm <expeditioneer@gentoo.org>
Sat, 26 Dec 2015 11:13:50 +0000 (12:13 +0100)
committerDennis Lamm <expeditioneer@gentoo.org>
Sat, 26 Dec 2015 11:14:58 +0000 (12:14 +0100)
Package-Manager: portage-2.2.24

gnome-extra/gnome-dvb-daemon/Manifest
gnome-extra/gnome-dvb-daemon/gnome-dvb-daemon-0.2.10.ebuild
gnome-extra/gnome-dvb-daemon/gnome-dvb-daemon-0.2.90.ebuild [new file with mode: 0644]

index 3d742554d249c194b8f6873cde7ed860a82df5c3..413ebc89fb7c01757f2387e9fbfc5580f5378b4b 100644 (file)
@@ -1 +1,2 @@
 DIST gnome-dvb-daemon-0.2.10.tar.xz 696372 SHA256 c23fcd4744c91bda065036a1a9b4a77b4665d7ca237f489e89a4c2f3133adcfb SHA512 9bf99f3b9d3c6a96a0fd193e41d98017f60ffa6255ae5fea52d2360fed0a3f292fc28c59060f54eb58e321e32e06693f5443bd3a4aba41cbd579a07a3c9691fb WHIRLPOOL 18eaa5739788ae3d9c44ce596105b64fcf608a875d4aba224abe18c8e1eac14d388c22126a61c92abe5efbf54c1cfc37400eb6b70fb457f597b4cdc1cb3573d6
+DIST gnome-dvb-daemon-0.2.90.tar.xz 700504 SHA256 8d1f3cc6cd8cdb5e032841ea136d27c432f2c8a9b9e46fc8e7d752e22c875a5f SHA512 73e18ed5b267f1ef1ceebfe4ff25ccac3222bca9d7da164dd16acf9367c6b9f9710e915c81ef851c54b6fcae9b08f36d0c78665f4af425afc41b4c08eba49c40 WHIRLPOOL 618584c1e25be5ef4ad4a6c551a61e9a8bab8f8d1b308e863193dbde97af44554b82116d6b1ec86d88367defdc76c8c50ea10e4bf19be54c8f5325f2169f12f6
index 1b2e4a9bf0b971dc7954353daca105464e6aa4a0..8036246d65177f2b8bd57c24637669d8532186d4 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -10,7 +10,7 @@ VALA_MIN_API_VERSION="0.16"
 inherit eutils python gnome2 multilib vala
 
 DESCRIPTION="Setup your DVB devices, record and watch TV shows and browse EPG using GStreamer"
-HOMEPAGE="https://live.gnome.org/DVBDaemon"
+HOMEPAGE="https://wiki.gnome.org/action/show/Projects/DVBDaemon"
 
 LICENSE="GPL-2"
 SLOT="0"
diff --git a/gnome-extra/gnome-dvb-daemon/gnome-dvb-daemon-0.2.90.ebuild b/gnome-extra/gnome-dvb-daemon/gnome-dvb-daemon-0.2.90.ebuild
new file mode 100644 (file)
index 0000000..1f7179a
--- /dev/null
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python{3_3,3_4} )
+VALA_MIN_API_VERSION="0.25"
+
+inherit eutils gnome2 multilib python-any-r1 vala
+
+DESCRIPTION="Setup your DVB devices, record and watch TV shows and browse EPG using GStreamer"
+HOMEPAGE="https://wiki.gnome.org/action/show/Projects/DVBDaemon"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="nls totem vala"
+
+RDEPEND=">=dev-libs/glib-2.32.0:2
+       >=media-libs/gstreamer-1.4.0:1.0
+       >=media-libs/gst-plugins-good-1.4.0:1.0
+       >=media-libs/gst-plugins-bad-1.4.0:1.0
+       >=dev-libs/libgee-0.8:0.8
+       >=dev-db/sqlite-3.4
+       >=media-libs/gst-rtsp-server-1.4.5:1.0
+       media-plugins/gst-plugins-dvb:1.0
+       dev-python/gst-python:1.0
+       >=dev-python/pygobject-3.2.1:3
+       >=dev-libs/gobject-introspection-1.44.0
+       x11-libs/gtk+:3[introspection]
+       virtual/libgudev
+       vala? ( $(vala_depend) )
+       totem? ( media-video/totem )"
+DEPEND="${RDEPEND}
+       ${PYTHON_DEPS}
+       >=dev-lang/perl-5.8.1
+       >=dev-util/intltool-0.40.0
+       virtual/pkgconfig
+       nls? ( sys-devel/gettext )
+       >=sys-devel/libtool-2.2.6"
+
+pkg_setup() {
+       G2CONF="${G2CONF} \
+               $(use_enable nls)
+               $(use_enable totem totem-plugin)"
+       use totem && G2CONF="${G2CONF} \
+               --with-totem-plugin-dir=/usr/$(get_libdir)/totem/plugins"
+       python-any-r1_pkg_setup
+}
+
+src_prepare() {
+       python_fix_shebang .
+       gnome2_src_prepare
+       use vala && vala_src_prepare
+}
+
+pkg_postinst() {
+       use totem && python_optimize
+       gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+       use totem && python_optimize
+       gnome2_pkg_postrm
+}