gnome-extra/evolution-data-server: Drop dependency on python
authorJan Vesely <jano.vesely@gmail.com>
Sun, 5 Apr 2020 16:40:23 +0000 (12:40 -0400)
committerMart Raudsepp <leio@gentoo.org>
Wed, 22 Apr 2020 16:12:49 +0000 (19:12 +0300)
Build system dependency on python was removed back in 3.28 [0]
[0] https://gitlab.gnome.org/GNOME/evolution-data-server/-/commit/a28389bae67f09a12e093998aa29956c66a7b359

Closes: https://bugs.gentoo.org/713058
Signed-off-by: Jan Vesely <jano.vesely@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/15236
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
gnome-extra/evolution-data-server/evolution-data-server-3.32.5.ebuild
gnome-extra/evolution-data-server/evolution-data-server-3.34.4.ebuild

index 1c26f9c18beccd67defb0f25edaf2deea385334f..d6a2e24c528eef64509a783aadb08375aec95454 100644 (file)
@@ -2,10 +2,9 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python3_6 )
 VALA_USE_DEPEND="vapigen"
 
-inherit cmake-utils db-use flag-o-matic gnome2 python-any-r1 systemd vala virtualx
+inherit cmake-utils db-use flag-o-matic gnome2 systemd vala virtualx
 
 DESCRIPTION="Evolution groupware backend"
 HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
@@ -58,7 +57,6 @@ RDEPEND="
        weather? ( >=dev-libs/libgweather-3.10:2= )
 "
 DEPEND="${RDEPEND}
-       ${PYTHON_DEPS}
        dev-util/gdbus-codegen
        dev-util/glib-utils
        dev-util/gperf
@@ -75,10 +73,6 @@ DEPEND="${RDEPEND}
 # It looks like a nightmare to disable those for now.
 RESTRICT="test !test? ( test )"
 
-pkg_setup() {
-       python-any-r1_pkg_setup
-}
-
 # global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare call
 src_prepare() {
        eapply "${FILESDIR}"/3.32.4-gtk-doc-fix{1,2}.patch
index 83161debc3a744b5fc15fd6de9ec9a658057ed3f..5038eb72784e16ac9c75301877533e2f0892a3a1 100644 (file)
@@ -2,10 +2,9 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python3_6 )
 VALA_USE_DEPEND="vapigen"
 
-inherit cmake-utils db-use flag-o-matic gnome2 python-any-r1 systemd vala virtualx
+inherit cmake-utils db-use flag-o-matic gnome2 systemd vala virtualx
 
 DESCRIPTION="Evolution groupware backend"
 HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
@@ -58,7 +57,6 @@ RDEPEND="
        weather? ( >=dev-libs/libgweather-3.10:2= )
 "
 DEPEND="${RDEPEND}
-       ${PYTHON_DEPS}
        dev-util/gdbus-codegen
        dev-util/glib-utils
        dev-util/gperf
@@ -78,10 +76,6 @@ DEPEND="${RDEPEND}
 # It looks like a nightmare to disable those for now.
 RESTRICT="test !test? ( test )"
 
-pkg_setup() {
-       python-any-r1_pkg_setup
-}
-
 # global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare call
 src_prepare() {
        use vala && vala_src_prepare