dev-python/pycurl: Skip gssapi tests to avoid [kerberos] dep
authorMichał Górny <mgorny@gentoo.org>
Mon, 16 Jul 2018 17:29:05 +0000 (19:29 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Jul 2018 17:41:01 +0000 (19:41 +0200)
Skip the gssapi tests which boil down to checking if gssapi option
is supported.  This lets us avoid forcing [kerberos] on net-libs/curl.

dev-python/pycurl/pycurl-7.43.0.2.ebuild

index 3b07c860bc35dd8a5bee73157518cbf0f7630bf5..f88599c7048639e3fb4d55849d946d057c854399 100644 (file)
@@ -40,7 +40,7 @@ DEPEND="${RDEPEND}
                dev-python/bottle[${PYTHON_USEDEP}]
                dev-python/flaky[${PYTHON_USEDEP}]
                dev-python/nose[${PYTHON_USEDEP}]
-               net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_libressl(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),http2,kerberos]
+               net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_libressl(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),http2]
                >=dev-python/bottle-0.12.7[${PYTHON_USEDEP}]
        )"
 # Needed for individual runs of testsuite by python impls.
@@ -62,7 +62,7 @@ python_compile() {
 }
 
 python_test() {
-       nosetests -a '!standalone' -v --with-flaky || die "Tests fail with ${EPYTHON}"
+       nosetests -a '!standalone,!gssapi' -v --with-flaky || die "Tests fail with ${EPYTHON}"
 }
 
 python_install_all() {