media-gfx/cropgui: Re-add cropgui.
authorHanno Böck <hanno@gentoo.org>
Mon, 23 Mar 2020 06:39:27 +0000 (07:39 +0100)
committerHanno Böck <hanno@gentoo.org>
Mon, 23 Mar 2020 06:39:27 +0000 (07:39 +0100)
This version is python 3 compatible.

Bug: https://bugs.gentoo.org/708098
Signed-off-by: Hanno Böck <hanno@gentoo.org>
Package-Manager: Portage-2.3.94, Repoman-2.3.21

media-gfx/cropgui/Manifest [new file with mode: 0644]
media-gfx/cropgui/cropgui-0.4.1.ebuild [new file with mode: 0644]
media-gfx/cropgui/metadata.xml [new file with mode: 0644]

diff --git a/media-gfx/cropgui/Manifest b/media-gfx/cropgui/Manifest
new file mode 100644 (file)
index 0000000..3363c1a
--- /dev/null
@@ -0,0 +1 @@
+DIST cropgui-0.4.1.tar.gz 852958 BLAKE2B dcc6ba775e49af9a9fe1054fe5246e87e044f47cb7ca20712e5048dd1fa0fda35ee90c38cf733540913d0220eb58ab0a6dcfe93c7b02ebb9e022529b8add6c1c SHA512 85b0c2c57faecdd7db15e417234f2ea50fc5edbdcacaedcfc53cda68c3a070f4ba0201bff9afbaa3de7c51552309df1ac3e87586b4021e68bbb255a2545d92da
diff --git a/media-gfx/cropgui/cropgui-0.4.1.ebuild b/media-gfx/cropgui/cropgui-0.4.1.ebuild
new file mode 100644 (file)
index 0000000..867b72d
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit eutils python-r1 desktop xdg-utils
+
+DESCRIPTION="GUI for lossless cropping of jpeg images"
+HOMEPAGE="https://emergent.unpythonic.net/01248401946"
+SRC_URI="https://github.com/jepler/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${PYTHON_DEPS}
+       dev-python/pillow[${PYTHON_USEDEP}]
+       dev-python/pygobject:3[${PYTHON_USEDEP}]"
+
+install_cropgui_wrapper() {
+       python_domodule cropgtk.py cropgui_common.py filechooser.py cropgui.glade
+       make_wrapper "${PN}.tmp" "${PYTHON} $(python_get_sitedir)/${PN}/cropgtk.py"
+       python_newexe "${ED}/usr/bin/${PN}.tmp" "${PN}"
+       rm "${ED}/usr/bin/${PN}.tmp" || die
+}
+
+src_install() {
+       python_moduleinto "${PN}"
+       python_foreach_impl install_cropgui_wrapper
+
+       domenu "${PN}.desktop"
+       doicon "${PN}.png"
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+}
diff --git a/media-gfx/cropgui/metadata.xml b/media-gfx/cropgui/metadata.xml
new file mode 100644 (file)
index 0000000..27aa4f8
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>hanno@gentoo.org</email>
+               <name>Hanno Böck</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">jepler/cropgui</remote-id>
+       </upstream>
+</pkgmetadata>