sci-electronics/gazebo: bump to 9.6.0
authorAlexis Ballier <aballier@gentoo.org>
Thu, 20 Dec 2018 16:10:00 +0000 (17:10 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 20 Dec 2018 16:10:10 +0000 (17:10 +0100)
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
sci-electronics/gazebo/Manifest
sci-electronics/gazebo/gazebo-9.6.0.ebuild [new file with mode: 0644]

index e7a34c9beb89468dc74405c1760bbe563496f421..e0aa0a8f63d0ec01ed88b9e0839bb69140727cb8 100644 (file)
@@ -1 +1,2 @@
 DIST gazebo-9.4.1.tar.bz2 53014386 BLAKE2B c3e450f869f3e5f88bd9b5f5924a6b003880fff492849d6570222c7c37e98f1b89df4dca1af16c9a766b049067bbcc9d86334882041c6420b6b5221dfd643bb0 SHA512 76fb217c396f4d70fa4617df3aa5a672b5ddd4680df22eb3fbe67182ef8b3e05affda2e61f71d03e31f9c47b2f7d56aac162b63dec2f122cef1e47fd65d25f02
+DIST gazebo-9.6.0.tar.bz2 52899944 BLAKE2B a1ae213cb81cbfbb62fb8a229f12c0c95c4325a8f2a1aae0d07dfaa3bdf17f4d4c3043f37efb5d407fb34073b354d83e7114e166225b8c90e87329abe1618059 SHA512 ef0cc95897322304e0117947e4b45dfb2c4ef3a24f3fa8c798397b3c6cf68b8193b7013efcf15a01f45b15caeae02ed7dacc53ae3b5dc8fcd393018b33bd3d14
diff --git a/sci-electronics/gazebo/gazebo-9.6.0.ebuild b/sci-electronics/gazebo/gazebo-9.6.0.ebuild
new file mode 100644 (file)
index 0000000..d1bd0c5
--- /dev/null
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils versionator vcs-snapshot flag-o-matic
+
+DESCRIPTION="A 3D multiple robot simulator with dynamics"
+HOMEPAGE="http://gazebosim.org/"
+SRC_URI="https://osrf-distributions.s3.amazonaws.com/gazebo/releases/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+# Subslot = major version = soname of libs
+SLOT="0/9"
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_sse2 libav test"
+
+RDEPEND="
+       >=dev-libs/protobuf-2:=
+       virtual/opengl
+       media-libs/openal
+       net-misc/curl
+       dev-libs/tinyxml
+       >=dev-libs/tinyxml2-6:=
+       dev-libs/libtar
+       dev-cpp/tbb
+       >=dev-games/ogre-1.7.4:=[freeimage]
+       <dev-games/ogre-1.10
+       >=media-libs/freeimage-3.15.4[png]
+       sci-libs/libccd
+       libav? ( >=media-video/libav-9:0= )
+       !libav? ( >=media-video/ffmpeg-2.6:0= )
+       sci-libs/gts
+       >=sci-physics/bullet-2.82
+       >=dev-libs/sdformat-6.0:=
+       dev-qt/qtwidgets:5
+       dev-qt/qtcore:5
+       dev-qt/qtopengl:5
+       dev-libs/boost:=[threads]
+       sci-libs/gdal:=
+       virtual/libusb:1
+       dev-libs/libspnav
+       media-libs/freeimage
+       sci-libs/hdf5:=[cxx]
+       sys-apps/util-linux
+       media-gfx/graphviz
+       net-libs/ignition-msgs:1=
+       sci-libs/ignition-math:4=
+       net-libs/ignition-transport:4=
+       x11-libs/qwt:6=[qt5(+)]
+"
+DEPEND="${RDEPEND}
+       dev-qt/qttest:5
+       app-text/ronn
+       app-arch/gzip
+       virtual/pkgconfig
+       x11-apps/mesa-progs
+       test? ( dev-libs/libxslt )
+"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+PATCHES=( "${FILESDIR}/qwt.patch" )
+
+src_configure() {
+       # doesnt build without it
+       append-cxxflags "-std=c++11"
+       # doesnt build with as-needed either
+       append-ldflags "-Wl,--no-as-needed"
+
+       local mycmakeargs=(
+               "-DUSE_UPSTREAM_CFLAGS=OFF"
+               "-DSSE2_FOUND=$(usex cpu_flags_x86_sse2 TRUE FALSE)"
+               "-DUSE_HOST_CFLAGS=FALSE"
+               "-DBUILD_TESTING=$(usex test TRUE FALSE)"
+               "-DENABLE_SCREEN_TESTS=FALSE"
+               "-DUSE_EXTERNAL_TINYXML2=TRUE"
+       )
+       cmake-utils_src_configure
+}