dev-ml/ppx_pipebang: bump to 113.33.00
authorAlexis Ballier <aballier@gentoo.org>
Tue, 22 Mar 2016 09:02:57 +0000 (10:02 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 22 Mar 2016 09:20:07 +0000 (10:20 +0100)
Package-Manager: portage-2.2.28
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ml/ppx_pipebang/Manifest
dev-ml/ppx_pipebang/ppx_pipebang-113.33.00.ebuild [new file with mode: 0644]

index 125213d97bb5c2913fc55725d8ed24603db15519..4ac12fee5c23b71c375c54ac8cc4b8b1fcc367c7 100644 (file)
@@ -1 +1,2 @@
 DIST ppx_pipebang-113.24.00.tar.gz 51430 SHA256 11bc7a7c62e3fc6ac3d437c1411e746ccc01d23b1bbdcc5333c562dc343ddcf0 SHA512 12f918ca1c8d16163009f12af2bc8b5652918d53905fb7c85587925960ff483e671eb210ee93c74002375cd608cbc3fd257dd28acc7963ffd227aeb2217f5041 WHIRLPOOL 20076a4da7633d9d0fe930b2d827f8069b72924a1d1e44f3f4175193116180911c27971ff2834406af81e73a1664c1c59f33d87cd3ba1d0d5e29506581f543b0
+DIST ppx_pipebang-113.33.00.tar.gz 51353 SHA256 6e43998c5161b87f71a38d197f9d5898ab8ac0e8f7612db64b5c848ee6709204 SHA512 9c057c756b3dbf0ad2306cfc61e9874cb11e050ade05ab2686cfd043fec5e52c17c197aaf6f3ba65c032aa66e810964c4c03b72af64f98e47bf8d532806f62e8 WHIRLPOOL 7a61889c3857591b7f596874d6665f55065d826ed1c6bf645c541816aeafbefec528826dfb48914d875ee9c6ce30f2709d9798aed4d46487827baa2a43eef920
diff --git a/dev-ml/ppx_pipebang/ppx_pipebang-113.33.00.ebuild b/dev-ml/ppx_pipebang/ppx_pipebang-113.33.00.ebuild
new file mode 100644 (file)
index 0000000..ae35794
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="A ppx rewriter that inlines reverse application operators |> and |!"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-ml/ppx_tools:=
+       dev-ml/ppx_core:=
+       dev-ml/ppx_driver:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+       emake setup.exe
+       OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+       emake
+}
+
+src_install() {
+       opam-installer -i \
+               --prefix="${ED}/usr" \
+               --libdir="${D}/$(ocamlc -where)" \
+               --docdir="${ED}/usr/share/doc/${PF}" \
+               ${PN}.install || die
+       dodoc README.md
+}