dev-python/os-diskconfig-python-novaclient-ext: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Wed, 19 Jun 2019 08:32:34 +0000 (10:32 +0200)
committerDavid Seifert <soap@gentoo.org>
Wed, 19 Jun 2019 08:32:34 +0000 (10:32 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/os-diskconfig-python-novaclient-ext/os-diskconfig-python-novaclient-ext-0.1.3.ebuild

index b04b5d5a5356bd325c04e3554b67e7752ad92778..a7fc14c14038715c768608b2e410219c65477cc6 100644 (file)
@@ -1,20 +1,21 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
 
 inherit distutils-r1
 
 DESCRIPTION="Disk Config extension for python-novaclient"
-HOMEPAGE="https://github.com/rackspace/os_diskconfig_python_novaclient_ext"
+HOMEPAGE="https://github.com/rackerlabs/os_diskconfig_python_novaclient_ext"
 SRC_URI="mirror://pypi/${PN:0:1}/os_diskconfig_python_novaclient_ext/os_diskconfig_python_novaclient_ext-${PV}.tar.gz"
 
 LICENSE="Apache-2.0"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
 
-S="${WORKDIR}/os_diskconfig_python_novaclient_ext-${PV}"
-
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 RDEPEND=">=dev-python/python-novaclient-2.10.0[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${PN//-/_}-${PV}"