app-i18n/ibus-anthy: use xdg eclass
authorAkinori Hattori <hattya@gentoo.org>
Thu, 14 May 2020 14:23:34 +0000 (23:23 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Thu, 14 May 2020 14:36:12 +0000 (23:36 +0900)
Bug: https://bugs.gentoo.org/722758
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
app-i18n/ibus-anthy/ibus-anthy-1.5.10-r2.ebuild [moved from app-i18n/ibus-anthy/ibus-anthy-1.5.10-r1.ebuild with 93% similarity]
app-i18n/ibus-anthy/ibus-anthy-1.5.11-r1.ebuild [moved from app-i18n/ibus-anthy/ibus-anthy-1.5.11.ebuild with 92% similarity]

similarity index 93%
rename from app-i18n/ibus-anthy/ibus-anthy-1.5.10-r1.ebuild
rename to app-i18n/ibus-anthy/ibus-anthy-1.5.10-r2.ebuild
index f8d2fd9b0ff5a3680f7223bdf0a296824f5b6bc0..069c762f0ac737c0fe96149912c48c78c3669c75 100644 (file)
@@ -4,7 +4,7 @@
 EAPI="7"
 PYTHON_COMPAT=( python3_{6,7,8} )
 
-inherit gnome2-utils python-single-r1
+inherit gnome2-utils python-single-r1 xdg
 
 DESCRIPTION="Japanese Anthy engine for IBus"
 HOMEPAGE="https://github.com/ibus/ibus/wiki"
@@ -53,10 +53,12 @@ src_install() {
 }
 
 pkg_preinst() {
+       xdg_pkg_preinst
        gnome2_icon_savelist
 }
 
 pkg_postinst() {
+       xdg_pkg_postinst
        gnome2_icon_cache_update
 
        if ! has_version app-dicts/kasumi; then
@@ -65,5 +67,6 @@ pkg_postinst() {
 }
 
 pkg_postrm() {
+       xdg_pkg_postrm
        gnome2_icon_cache_update
 }
similarity index 92%
rename from app-i18n/ibus-anthy/ibus-anthy-1.5.11.ebuild
rename to app-i18n/ibus-anthy/ibus-anthy-1.5.11-r1.ebuild
index b818978cb1ad7cf8652af71c868900888b0248b9..f1381ad5b3aa909a126994c105ac8eef5d76c009 100644 (file)
@@ -4,7 +4,7 @@
 EAPI="7"
 PYTHON_COMPAT=( python3_{6,7,8} )
 
-inherit gnome2-utils python-single-r1
+inherit gnome2-utils python-single-r1 xdg
 
 DESCRIPTION="Japanese Anthy engine for IBus"
 HOMEPAGE="https://github.com/ibus/ibus/wiki"
@@ -52,10 +52,12 @@ src_install() {
 }
 
 pkg_preinst() {
+       xdg_pkg_preinst
        gnome2_icon_savelist
 }
 
 pkg_postinst() {
+       xdg_pkg_postinst
        gnome2_icon_cache_update
 
        if ! has_version app-dicts/kasumi; then
@@ -64,5 +66,6 @@ pkg_postinst() {
 }
 
 pkg_postrm() {
+       xdg_pkg_postrm
        gnome2_icon_cache_update
 }