net-misc/chrome-remote-desktop: switch to python eclasses #561414
authorMike Frysinger <vapier@gentoo.org>
Sat, 26 Sep 2015 07:31:03 +0000 (03:31 -0400)
committerMike Frysinger <vapier@gentoo.org>
Sat, 26 Sep 2015 08:07:42 +0000 (04:07 -0400)
This code only works with python-2.7, so make sure we limit ourselves
and write the scripts as such.

net-misc/chrome-remote-desktop/chrome-remote-desktop-45.0.2454.17-r2.ebuild [moved from net-misc/chrome-remote-desktop/chrome-remote-desktop-45.0.2454.17-r1.ebuild with 95% similarity]

similarity index 95%
rename from net-misc/chrome-remote-desktop/chrome-remote-desktop-45.0.2454.17-r1.ebuild
rename to net-misc/chrome-remote-desktop/chrome-remote-desktop-45.0.2454.17-r2.ebuild
index 52f80d8b26cfd783ece872d8bf0471c61561907e..0d5ffcf7dc53bef69b3cbb6100277bcb456cbbcd 100644 (file)
 # Use curl to find the answer:
 #  curl -q https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/main/binary-i386/Packages | grep ^Filename
 
-EAPI="4"
+EAPI="5"
 
-inherit unpacker eutils
+PYTHON_COMPAT=( python2_7 )
+
+inherit unpacker eutils python-single-r1
 
 DESCRIPTION="access remote computers via Chrome!"
 PLUGIN_URL="https://chrome.google.com/remotedesktop"
@@ -32,7 +34,7 @@ IUSE=""
 
 # All the libs this package links against.
 RDEPEND="app-admin/sudo
-       dev-lang/python
+       ${PYTHON_DEPS}
        >=dev-libs/expat-2
        dev-libs/glib:2
        dev-libs/nspr
@@ -65,6 +67,7 @@ QA_PREBUILT="/opt/google/chrome-remote-desktop/*"
 
 src_prepare() {
        epatch "${FILESDIR}"/${PN}-44.0.2403.44-always-sudo.patch #541708
+       python_fix_shebang opt/google/chrome-remote-desktop/chrome-remote-desktop
 }
 
 src_install() {