media-sound/opus-tools: Bump to version 0.1.10
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 26 Jan 2017 23:31:26 +0000 (00:31 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 26 Jan 2017 23:36:52 +0000 (00:36 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

media-sound/opus-tools/Manifest
media-sound/opus-tools/opus-tools-0.1.10.ebuild [new file with mode: 0644]

index cbaf6a9a44ffde98f2d8784161fe0fa62a853939..b4666f97e419f4b6264fa3e8283769723ee6a028 100644 (file)
@@ -1 +1,2 @@
+DIST opus-tools-0.1.10.tar.gz 312093 SHA256 a2357532d19471b70666e0e0ec17d514246d8b3cb2eb168f68bb0f6fd372b28c SHA512 4ead97b9fe4658968a4b5cbe4bde5e2d8cbfaaea18dd0d817597cc6b6b11f26937b9eee7358ade63568f0213131aa80ecbed169d1b3885980a556871a4a7fe98 WHIRLPOOL 8ecfdf10c55adda1a05f76a515b8583e56e5e80a32fcfda8fbf0db9026e9e3a176c90ef11782d89264e4c85ca139e20c15934790355c2c7c3646a74a248e2816
 DIST opus-tools-0.1.9.tar.gz 385158 SHA256 b1873dd78c7fbc98cf65d6e10cfddb5c2c03b3af93f922139a2104baedb4643a SHA512 e2cdc0c9c24297565f9d457893bcc548696b1a9c9b66e4cd48ddbe4dcf865bc50da5ed1b438b2b9ecdcd8be1d7c211d2be199f707cdbcd8a46a75353b0173a4c WHIRLPOOL c0acf53763c6263ece4b8b796373ba689006282987043ed15c3d747d08cc9fae76e968a643919b4d9d08a00acc9b8ad46e4fefbdd43263d7293ae2fb93e88278
diff --git a/media-sound/opus-tools/opus-tools-0.1.10.ebuild b/media-sound/opus-tools/opus-tools-0.1.10.ebuild
new file mode 100644 (file)
index 0000000..786c606
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Royalty-free, highly versatile audio codec"
+HOMEPAGE="http://opus-codec.org/"
+
+if [[ ${PV} == *9999 ]] ; then
+       inherit git-2
+       EGIT_REPO_URI="git://git.opus-codec.org/${PN}.git"
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+       SRC_URI="https://dev.gentoo.org/~lu_zero/${PN}/${P}.tar.xz"
+else # Official release
+       SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="flac"
+
+RDEPEND=">=media-libs/libogg-1.3.0
+        >=media-libs/opus-1.0.3
+        flac? ( >=media-libs/flac-1.1.3 )"
+DEPEND="virtual/pkgconfig
+       ${RDEPEND}"
+
+src_prepare() {
+       default
+       [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+       econf $(use_with flac)
+}
+
+src_install() {
+       default
+       find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}