app-emacs/bongo: Bump to version 1.1.
authorUlrich Müller <ulm@gentoo.org>
Tue, 3 Sep 2019 11:43:16 +0000 (13:43 +0200)
committerUlrich Müller <ulm@gentoo.org>
Tue, 3 Sep 2019 11:45:11 +0000 (13:45 +0200)
Package-Manager: Portage-2.3.75, Repoman-2.3.17
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-emacs/bongo/Manifest
app-emacs/bongo/bongo-1.1.ebuild [new file with mode: 0644]

index 81da00ff80813e40a5be54fa8e511fb290c73c83..4dffab39e1e399b5a71c27d93a10bbfdfc804b6a 100644 (file)
@@ -1,2 +1,3 @@
+DIST bongo-1.1.tar.gz 123552 BLAKE2B 06ee27b9ea77b3227038cd18767d8398e416f43a8cdd0a3ed08831200f2edf42eb1c4ab45d363e289b5a471a4ccd60ccb4efc00d62b225eb589dee96c255d7d5 SHA512 c2a4c4241da3ca432b481f56758958a56f749a25eed345d0f30fe560319fd646712b84751212582c2f4ba410cb8858881150b77166fe919725cc50e3917c98e8
 DIST bongo-20110621.tar.xz 97652 BLAKE2B a3fd04f24b122af580e75ed68ad42dcd99045ab9cc7ea9fd273c9b256dc732fd6a0328f15489a50b427c85dad4de1ea2254afc257a9e3f2896baeefc1cff1c56 SHA512 31c2a477cfb5ff36fbc64da29c725db0b0242ea09f80883fb21feb3b23f5c14c688379c4c4e53b26ffef3aca5d2813d5b2a38b91266da088c73516f7ea1d712b
 DIST bongo-mplayer-20070204.tar.bz2 3563 BLAKE2B 684c702da46fedd365f780b165619b20e5da643db7b457cc527017971e18a2b0e843896d28216527adbda1e6e7432ff081a7368b697256ac79f2032b30d97123 SHA512 e503ed7980f011a6fc3fa75d0bb9b1cec1ed49d4fb07da92aad65e3c5096b42cf9eb203a8edbb93f2e7924254e4926e9f3fcf473de877fea130557aefad73ebd
diff --git a/app-emacs/bongo/bongo-1.1.ebuild b/app-emacs/bongo/bongo-1.1.ebuild
new file mode 100644 (file)
index 0000000..a260dc9
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="Buffer-oriented media player for Emacs"
+HOMEPAGE="https://www.emacswiki.org/emacs/Bongo"
+SRC_URI="https://github.com/dbrock/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+       mplayer? ( mirror://gentoo/${PN}-mplayer-20070204.tar.bz2 )"
+
+LICENSE="GPL-2+ FDL-1.2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mplayer"
+
+# NOTE: Bongo can use almost anything for playing media files, therefore
+# the dependency possibilities are so broad that we refrain from including
+# any media players explicitly in DEPEND/RDEPEND.
+
+RDEPEND="app-emacs/volume"
+BDEPEND="${RDEPEND}
+       sys-apps/texinfo"
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="${PN}.texi"
+DOCS="NEWS README TODO tree-from-tags.rb"
+
+src_unpack() {
+       elisp_src_unpack
+       if use mplayer; then
+               mv ${PN}/bongo-mplayer.el "${S}"/ || die
+       fi
+}
+
+src_compile() {
+       # volume.el calls amixer in global scope, causing a sandbox violation
+       # in /dev/snd/. Work around it by disabling the mixer programs.
+       cat <<-EOF >nomixer.txt || die
+               (setq volume-amixer-program "/bin/false")
+               (setq volume-aumix-program "/bin/false")
+       EOF
+       BYTECOMPFLAGS+=" -l nomixer.txt"
+       elisp_src_compile
+}
+
+src_install() {
+       elisp_src_install
+       insinto "${SITEETC}/${PN}"
+       doins images/*.pbm images/*.png
+}