sci-chemistry/ghemical: Fix building against GCC 9
authorDavid Seifert <soap@gentoo.org>
Sun, 23 Jun 2019 13:10:45 +0000 (15:10 +0200)
committerDavid Seifert <soap@gentoo.org>
Sun, 23 Jun 2019 13:10:45 +0000 (15:10 +0200)
Closes: https://bugs.gentoo.org/687450
Package-Manager: Portage-2.3.67, Repoman-2.3.15
Signed-off-by: David Seifert <soap@gentoo.org>
sci-chemistry/ghemical/files/3.0.0-fix-gcc9.patch [new file with mode: 0644]
sci-chemistry/ghemical/ghemical-3.0.0.ebuild

diff --git a/sci-chemistry/ghemical/files/3.0.0-fix-gcc9.patch b/sci-chemistry/ghemical/files/3.0.0-fix-gcc9.patch
new file mode 100644 (file)
index 0000000..d3d80bb
--- /dev/null
@@ -0,0 +1,37 @@
+https://bugs.gentoo.org/687450
+
+project.h:210:14: error: friend declaration of ‘bool ReadGPR_OLD(project&, std::istream&, bool, bool)’ specifies default arguments and isn’t a definition [-fpermissive]
+  210 |  friend bool ReadGPR_OLD(project &, istream &, bool, bool = false);  ///< this is for the very old version.
+      |              ^~~~~~~~~~~
+
+--- a/src/project.h
++++ b/src/project.h
+@@ -122,6 +122,12 @@
+       graphical user interface.
+ */
++class project;
++bool ReadGPR_OLD(project &, istream &, bool, bool = false);
++bool ReadGPR_v100(project &, istream &, bool, bool = false);
++bool ReadGPR_v110(project &, istream &, bool, bool = false);
++bool ReadGPR(project &, istream &, bool, bool = false);
++
+ class project :
+       public custom_transformer_client,
+       public model
+@@ -207,11 +213,11 @@
+ // methods for file I/O : ReadGPR and WriteGPR are friend functions so that it would be easier to "borrow" them elsewhere...
+ // ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
+-      friend bool ReadGPR_OLD(project &, istream &, bool, bool = false);              ///< this is for the very old version.
+-      friend bool ReadGPR_v100(project &, istream &, bool, bool = false);             ///< this is for the version 1.00.
+-      friend bool ReadGPR_v110(project &, istream &, bool, bool = false);             ///< this is for the version 1.10.
++      friend bool ReadGPR_OLD(project &, istream &, bool, bool);              ///< this is for the very old version.
++      friend bool ReadGPR_v100(project &, istream &, bool, bool);             ///< this is for the version 1.00.
++      friend bool ReadGPR_v110(project &, istream &, bool, bool);             ///< this is for the version 1.10.
+ /// This is an input function for the v1.11 ghemical file format.
+-      friend bool ReadGPR(project &, istream &, bool, bool = false);
++      friend bool ReadGPR(project &, istream &, bool, bool);
+       
+       friend void WriteGPR_v100(project &, ostream &);        ///< this is for the version 1.00.
+ /// This is an output function for the v1.11 ghemical file format.
index 4186af7e725a621975eaf0a8f77c0e17af851e22..477c41439c286ebcdde17fe67ff1dc8931833745 100644 (file)
@@ -28,7 +28,10 @@ RDEPEND="
 DEPEND="${RDEPEND}
        virtual/pkgconfig"
 
-PATCHES=( "${FILESDIR}"/2.99.2-docs.patch )
+PATCHES=(
+       "${FILESDIR}"/2.99.2-docs.patch
+       "${FILESDIR}"/3.0.0-fix-gcc9.patch
+)
 
 src_prepare() {
        default