media-sound/pulseaudio-modules-bt: Bump to v1.3
authorPacho Ramos <pacho@gentoo.org>
Sun, 20 Oct 2019 11:37:53 +0000 (13:37 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sun, 20 Oct 2019 11:39:16 +0000 (13:39 +0200)
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
media-sound/pulseaudio-modules-bt/Manifest [new file with mode: 0644]
media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.3.ebuild [new file with mode: 0644]

diff --git a/media-sound/pulseaudio-modules-bt/Manifest b/media-sound/pulseaudio-modules-bt/Manifest
new file mode 100644 (file)
index 0000000..f2495fd
--- /dev/null
@@ -0,0 +1,2 @@
+DIST pulseaudio-13.0.tar.xz 1901768 BLAKE2B 651a80f54525f196bcb036d893fedd4d9f34e10459918281397a45f498c31bff0d0c836f4e64aab5ac2612ffd5a0cab1a41ea710bbee5fd34dfc9ea1236deea9 SHA512 d445b8ccd43029a0ca0e456fc9291a79d3434d6496ead7eb329ab348d5249235e8bde6cf2be68765d8f761452dbe1486fb10c739e40b1e67ed75787bbd24ac0c
+DIST pulseaudio-modules-bt-1.3.tar.gz 85802 BLAKE2B ea7e5141d07c1d3b19372cbae2aa9a5b6049509a12bb2470f47f231f85cc66ef4a74e70bdc91d3554d57e9c26b64129f87b2a3a55e16fbf0c6fe1b5ce7721074 SHA512 094c4205c1c71326efd42053a1bc9f131633c9e28fde177f1c08a290395864b76b8f60f79ffec2fbb8445186aa5c85aafabc47908fd302beb5b278ebcac98558
diff --git a/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.3.ebuild b/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.3.ebuild
new file mode 100644 (file)
index 0000000..73db43e
--- /dev/null
@@ -0,0 +1,71 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake-utils readme.gentoo-r1
+
+DESCRIPTION="PulseAudio modules for LDAC, aptX, aptX HD, and AAC for Bluetooth (alongside SBC and native+ofono headset)"
+HOMEPAGE="https://github.com/EHfive/pulseaudio-modules-bt"
+
+PULSE_VER="13.0"
+SRC_URI="
+       https://github.com/EHfive/pulseaudio-modules-bt/archive/v${PV}.tar.gz -> ${P}.tar.gz
+       https://freedesktop.org/software/pulseaudio/releases/pulseaudio-${PULSE_VER}.tar.xz
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+       media-libs/fdk-aac:0=
+       virtual/ffmpeg
+       media-libs/sbc
+       media-libs/libldac
+       >=net-wireless/bluez-5
+       >=sys-apps/dbus-1.0.0
+       >=net-misc/ofono-1.13
+       >=media-sound/pulseaudio-${PULSE_VER}[-bluetooth]
+"
+# Ordinarily media-libs/libldac should be in DEPEND too, but for now upstream repo is using a ldac submodule instead.
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+CMAKE_MAKEFILE_GENERATOR="emake"
+
+DISABLE_AUTOFORMATTING="no"
+DOC_CONTENTS="
+After getting media-sound/pulseaudio merged without its bluetooth
+support (to not collide with this) you may have removed the loading
+of bluetooth modules in default.pa config file, leading to failure
+to use your bluetooth device (see
+https://github.com/EHfive/pulseaudio-modules-bt/issues/33).
+Please ensure you have this lines present in your /etc/pulse/default.pa
+file:
+
+.ifexists module-bluetooth-policy.so
+load-module module-bluetooth-policy
+.endif
+
+.ifexists module-bluetooth-discover.so
+load-module module-bluetooth-discover
+.endif
+"
+
+src_prepare() {
+       cmake-utils_src_prepare
+       
+       # pulseaudio headers needed to build
+       rmdir pa/ || die
+       ln -s ../pulseaudio-${PULSE_VER}/ pa || die
+}
+
+src_install() {
+       cmake-utils_src_install
+       readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+       readme.gentoo_print_elog
+}